aboutsummaryrefslogtreecommitdiff
path: root/14.0.0
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-22 23:51:45 +0100
committerSam James <sam@gentoo.org>2023-10-22 23:51:51 +0100
commitaabcc9fe95c292c890038c9ba56c27cada2070bc (patch)
tree8b5a50afab95b2a7e00c16afb6b7429ac46563a5 /14.0.0
parent14.0.0: update 75_all_PR54179_genemit-Split-insn-emit.cc-into-ten-files.patch (diff)
downloadgcc-patches-aabcc9fe95c292c890038c9ba56c27cada2070bc.tar.gz
gcc-patches-aabcc9fe95c292c890038c9ba56c27cada2070bc.tar.bz2
gcc-patches-aabcc9fe95c292c890038c9ba56c27cada2070bc.zip
14.0.0: rebase 75_all_PR54179_genemit-Split-insn-emit.cc-into-ten-files.patch
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to '14.0.0')
-rw-r--r--14.0.0/gentoo/75_all_PR54179_genemit-Split-insn-emit.cc-into-ten-files.patch68
-rw-r--r--14.0.0/gentoo/README.history4
2 files changed, 24 insertions, 48 deletions
diff --git a/14.0.0/gentoo/75_all_PR54179_genemit-Split-insn-emit.cc-into-ten-files.patch b/14.0.0/gentoo/75_all_PR54179_genemit-Split-insn-emit.cc-into-ten-files.patch
index 723d78a..988c0f4 100644
--- a/14.0.0/gentoo/75_all_PR54179_genemit-Split-insn-emit.cc-into-ten-files.patch
+++ b/14.0.0/gentoo/75_all_PR54179_genemit-Split-insn-emit.cc-into-ten-files.patch
@@ -1,3 +1,6 @@
+https://gcc.gnu.org/PR54179
+https://inbox.sourceware.org/gcc-patches/de0f7bdc-d236-4f5b-9504-d5bfb215d023@gmail.com/
+
From 544943ea6b4d0e9a57408ca92464e22b84ffcb12 Mon Sep 17 00:00:00 2001
From: Robin Dapp <rdapp.gcc@gmail.com>
Date: Fri, 20 Oct 2023 13:27:41 +0200
@@ -43,19 +46,6 @@ gcc/ChangeLog:
* gensupport.h (count_patterns): Define.
* read-md.cc (md_reader::print_md_ptr_loc): Add file argument.
* read-md.h (class md_reader): Change definition.
----
- gcc/Makefile.in | 36 +++-
- gcc/configure | 24 ++-
- gcc/configure.ac | 13 ++
- gcc/genemit.cc | 536 +++++++++++++++++++++++++---------------------
- gcc/gensupport.cc | 36 ++++
- gcc/gensupport.h | 1 +
- gcc/read-md.cc | 4 +-
- gcc/read-md.h | 2 +-
- 8 files changed, 397 insertions(+), 255 deletions(-)
-
-diff --git a/gcc/Makefile.in b/gcc/Makefile.in
-index a25a1e32fbc..dc63c67409b 100644
--- a/gcc/Makefile.in
+++ b/gcc/Makefile.in
@@ -236,6 +236,13 @@ GIMPLE_MATCH_PD_SEQ_O = $(patsubst %, gimple-match-%.o, $(MATCH_SPLITS_SEQ))
@@ -72,7 +62,7 @@ index a25a1e32fbc..dc63c67409b 100644
# These files are to have specific diagnostics suppressed, or are not to
# be subject to -Werror:
# flex output may yield harmless "no previous prototype" warnings
-@@ -1354,7 +1361,7 @@ OBJS = \
+@@ -1356,7 +1363,7 @@ OBJS = \
insn-attrtab.o \
insn-automata.o \
insn-dfatab.o \
@@ -81,7 +71,7 @@ index a25a1e32fbc..dc63c67409b 100644
insn-extract.o \
insn-latencytab.o \
insn-modes.o \
-@@ -1854,7 +1861,8 @@ TREECHECKING = @TREECHECKING@
+@@ -1856,7 +1863,8 @@ TREECHECKING = @TREECHECKING@
FULL_DRIVER_NAME=$(target_noncanonical)-gcc-$(version)$(exeext)
MOSTLYCLEANFILES = insn-flags.h insn-config.h insn-codes.h \
@@ -91,7 +81,7 @@ index a25a1e32fbc..dc63c67409b 100644
insn-attr.h insn-attr-common.h insn-attrtab.cc insn-dfatab.cc \
insn-latencytab.cc insn-opinit.cc insn-opinit.h insn-preds.cc insn-constants.h \
tm-preds.h tm-constrs.h checksum-options $(GIMPLE_MATCH_PD_SEQ_SRC) \
-@@ -2483,11 +2491,11 @@ $(common_out_object_file): $(common_out_file)
+@@ -2488,11 +2496,11 @@ $(common_out_object_file): $(common_out_file)
# and compile them.
.PRECIOUS: insn-config.h insn-flags.h insn-codes.h insn-constants.h \
@@ -108,7 +98,7 @@ index a25a1e32fbc..dc63c67409b 100644
# Dependencies for the md file. The first time through, we just assume
# the md file itself and the generated dependency file (in order to get
-@@ -2510,7 +2518,7 @@ s-mddeps: $(md_file) $(MD_INCLUDES) build/genmddeps$(build_exeext)
+@@ -2515,7 +2523,7 @@ s-mddeps: $(md_file) $(MD_INCLUDES) build/genmddeps$(build_exeext)
simple_rtl_generated_h = insn-attr.h insn-attr-common.h insn-codes.h \
insn-config.h insn-flags.h insn-target-def.h
@@ -117,7 +107,7 @@ index a25a1e32fbc..dc63c67409b 100644
insn-extract.cc insn-output.cc \
insn-peep.cc insn-recog.cc
-@@ -2539,8 +2547,20 @@ $(simple_generated_c:insn-%.cc=s-%): s-%: build/gen%$(build_exeext)
+@@ -2544,8 +2552,20 @@ $(simple_generated_c:insn-%.cc=s-%): s-%: build/gen%$(build_exeext)
$(SHELL) $(srcdir)/../move-if-change tmp-$*.cc insn-$*.cc
$(STAMP) s-$*
@@ -139,10 +129,10 @@ index a25a1e32fbc..dc63c67409b 100644
s-check : build/gencheck$(build_exeext)
$(RUN_GEN) build/gencheck$(build_exeext) > tmp-check.h
diff --git a/gcc/configure b/gcc/configure
-index 9f5b7081992..cf35b8fac89 100755
+index c47a8c5..0e4e0e4 100755
--- a/gcc/configure
+++ b/gcc/configure
-@@ -842,6 +842,7 @@ enable_gcov
+@@ -844,6 +844,7 @@ enable_gcov
enable_shared
enable_fixed_point
enable_decimal_float
@@ -150,7 +140,7 @@ index 9f5b7081992..cf35b8fac89 100755
DEFAULT_MATCHPD_PARTITIONS
with_float
with_cpu
-@@ -971,6 +972,7 @@ enable_multilib
+@@ -973,6 +974,7 @@ enable_multilib
enable_multiarch
with_stack_clash_protection_guard_size
with_matchpd_partitions
@@ -158,7 +148,7 @@ index 9f5b7081992..cf35b8fac89 100755
enable___cxa_atexit
enable_decimal_float
enable_fixed_point
-@@ -1839,6 +1841,9 @@ Optional Packages:
+@@ -1846,6 +1848,9 @@ Optional Packages:
--with-matchpd-partitions=num
Set the number of partitions to make for gimple and
generic when splitting match.pd. [default=10]
@@ -168,7 +158,7 @@ index 9f5b7081992..cf35b8fac89 100755
--with-dwarf2 force the default debug format to be DWARF 2 (or
later)
--with-specs=SPECS add SPECS to driver command-line processing
-@@ -7938,6 +7943,21 @@ fi
+@@ -7941,6 +7946,21 @@ fi
@@ -190,29 +180,11 @@ index 9f5b7081992..cf35b8fac89 100755
# Enable __cxa_atexit for C++.
# Check whether --enable-__cxa_atexit was given.
if test "${enable___cxa_atexit+set}" = set; then :
-@@ -19923,7 +19943,7 @@ else
- lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
- lt_status=$lt_dlunknown
- cat > conftest.$ac_ext <<_LT_EOF
--#line 19926 "configure"
-+#line 19946 "configure"
- #include "confdefs.h"
-
- #if HAVE_DLFCN_H
-@@ -20029,7 +20049,7 @@ else
- lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
- lt_status=$lt_dlunknown
- cat > conftest.$ac_ext <<_LT_EOF
--#line 20032 "configure"
-+#line 20052 "configure"
- #include "confdefs.h"
-
- #if HAVE_DLFCN_H
diff --git a/gcc/configure.ac b/gcc/configure.ac
-index c10e007f9bf..eac2cadab00 100644
+index b443da5..d4a6fff 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
-@@ -956,6 +956,19 @@ fi
+@@ -949,6 +949,19 @@ fi
AC_SUBST(DEFAULT_MATCHPD_PARTITIONS)
@@ -233,7 +205,7 @@ index c10e007f9bf..eac2cadab00 100644
AC_ARG_ENABLE(__cxa_atexit,
[AS_HELP_STRING([--enable-__cxa_atexit], [enable __cxa_atexit for C++])],
diff --git a/gcc/genemit.cc b/gcc/genemit.cc
-index 1ce0564076d..8d8a3c4aa80 100644
+index 1ce0564..8d8a3c4 100644
--- a/gcc/genemit.cc
+++ b/gcc/genemit.cc
@@ -49,29 +49,29 @@ struct clobber_ent
@@ -1259,7 +1231,7 @@ index 1ce0564076d..8d8a3c4aa80 100644
+ return (fclose (file) != 0 ? FATAL_EXIT_CODE : SUCCESS_EXIT_CODE);
}
diff --git a/gcc/gensupport.cc b/gcc/gensupport.cc
-index dd920d673b4..367ba1a30a4 100644
+index dd920d6..367ba1a 100644
--- a/gcc/gensupport.cc
+++ b/gcc/gensupport.cc
@@ -3131,6 +3131,42 @@ init_rtx_reader_args (int argc, const char **argv)
@@ -1306,7 +1278,7 @@ index dd920d673b4..367ba1a30a4 100644
describing it in *INFO. */
diff --git a/gcc/gensupport.h b/gcc/gensupport.h
-index 7925e22ed41..7396118714b 100644
+index 7925e22..7396118 100644
--- a/gcc/gensupport.h
+++ b/gcc/gensupport.h
@@ -130,6 +130,7 @@ extern rtx add_implicit_parallel (rtvec);
@@ -1318,7 +1290,7 @@ index 7925e22ed41..7396118714b 100644
extern unsigned int get_num_insn_codes ();
diff --git a/gcc/read-md.cc b/gcc/read-md.cc
-index fd38818e3a3..46ab9065e3e 100644
+index fd38818..46ab906 100644
--- a/gcc/read-md.cc
+++ b/gcc/read-md.cc
@@ -132,9 +132,9 @@ md_reader::fprint_md_ptr_loc (FILE *outf, const void *ptr)
@@ -1334,7 +1306,7 @@ index fd38818e3a3..46ab9065e3e 100644
/* Return a condition that satisfies both COND1 and COND2. Either string
diff --git a/gcc/read-md.h b/gcc/read-md.h
-index b309c9c3deb..2adcb58478f 100644
+index b309c9c..2adcb58 100644
--- a/gcc/read-md.h
+++ b/gcc/read-md.h
@@ -194,7 +194,7 @@ class md_reader
diff --git a/14.0.0/gentoo/README.history b/14.0.0/gentoo/README.history
index 096dfcb..f8c8e61 100644
--- a/14.0.0/gentoo/README.history
+++ b/14.0.0/gentoo/README.history
@@ -1,3 +1,7 @@
+6 22 Oct 2023
+
+ U 75_all_PR54179_genemit-Split-insn-emit.cc-into-ten-files.patch
+
5 21 Oct 2023
U 75_all_PR54179_genemit-Split-insn-emit.cc-into-ten-files.patch