summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-02-29 03:54:49 +0300
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-02-29 03:54:49 +0300
commit3671ad51f7324cb19cb53f20badf308b831d01f8 (patch)
treea0c19302d7fcb7444395f212e79cf4cfe0949d35 /games-arcade
parentgames-arcade/tokitori: update package (diff)
downloadgamerlay-3671ad51f7324cb19cb53f20badf308b831d01f8.tar.gz
gamerlay-3671ad51f7324cb19cb53f20badf308b831d01f8.tar.bz2
gamerlay-3671ad51f7324cb19cb53f20badf308b831d01f8.zip
games-arcade/edge: update package
Migrate from deprecated eclass. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/edge/edge-20130703.ebuild24
-rw-r--r--games-arcade/edge/metadata.xml4
2 files changed, 16 insertions, 12 deletions
diff --git a/games-arcade/edge/edge-20130703.ebuild b/games-arcade/edge/edge-20130703.ebuild
index 6184fba..5b39dbb 100644
--- a/games-arcade/edge/edge-20130703.ebuild
+++ b/games-arcade/edge/edge-20130703.ebuild
@@ -1,6 +1,9 @@
-EAPI="5"
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
-inherit base games unpacker-nixstaller
+EAPI=7
+
+inherit eutils desktop unpacker-nixstaller
MY_PN="${PN^^}"
TS="1372878397"
@@ -11,13 +14,12 @@ HOMEPAGE="http://mobigame.net/"
SRC_URI="${MY_P}.sh"
RESTRICT="fetch"
-LICENSE="as-is"
+LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}
+RDEPEND="
media-libs/libsdl2
media-libs/openal
sys-libs/zlib
@@ -34,21 +36,22 @@ S="${WORKDIR}"
DOCS=( "README.linux" )
src_unpack() {
- local arch=x86
+ local arch
use amd64 && arch=x86_64
+ use x86 && arch=x86
nixstaller_unpack "instarchive_all" "instarchive_all_${arch}"
}
src_install() {
- local dir="${GAMES_PREFIX_OPT}/${PN}"
- local arch=x86
+ local dir="/opt/${PN}"
use amd64 && arch=x86_64
+ use x86 && arch=x86
exeinto "${dir}"
insinto "${dir}"
make_desktop_entry "${PN}" "${MY_PN}" "${PN}"
- games_make_wrapper "${PN}" "./${PN}" "${dir}"
+ make_wrapper "${PN}" "./${PN}" "${dir}"
newexe "${MY_PN}.bin.${arch}" "${PN}"
newicon "${MY_PN}.png" "${PN}.png"
@@ -68,8 +71,5 @@ src_install() {
"music" \
"sprites" \
"textures"
-
- prepgamesdirs
-
base_src_install_docs
}
diff --git a/games-arcade/edge/metadata.xml b/games-arcade/edge/metadata.xml
new file mode 100644
index 0000000..097975e
--- /dev/null
+++ b/games-arcade/edge/metadata.xml
@@ -0,0 +1,4 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+</pkgmetadata>