summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-02-29 16:56:17 +0300
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-02-29 16:56:17 +0300
commit3f47c660668392c1031c2fa89d99b815997c72d8 (patch)
treef7404a2862cbd9156adac2f3ac24c05aaafb07b9 /games-action
parentgames-action/shadowgrounds-bin: update package (diff)
downloadgamerlay-3f47c660668392c1031c2fa89d99b815997c72d8.tar.gz
gamerlay-3f47c660668392c1031c2fa89d99b815997c72d8.tar.bz2
gamerlay-3f47c660668392c1031c2fa89d99b815997c72d8.zip
games-action/shadowgrounds-survivor-bin: update
Migrate from deprecated eclass. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-1-r1.ebuild (renamed from games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-1.ebuild)24
1 files changed, 8 insertions, 16 deletions
diff --git a/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-1.ebuild b/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-1-r1.ebuild
index 46c911c..84c5440 100644
--- a/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-1.ebuild
+++ b/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-1-r1.ebuild
@@ -1,16 +1,15 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_beta11.ebuild,v 1.2 2011/04/21 08:50:11 vapier Exp $
-EAPI="5"
+EAPI=7
-inherit unpacker games eutils
+inherit desktop eutils multilib-minimal unpacker
DESCRIPTION="human survivors who battle against the ongoing alien onslaught"
HOMEPAGE="http://shadowgroundsgame.com/survivor/"
SRC_URI="survivorUpdate${PV}.run"
-LICENSE="frozenbyte-eula"
+LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE=""
@@ -19,16 +18,11 @@ RESTRICT="fetch strip"
DEPEND="app-arch/unzip"
RDEPEND=">=sys-libs/glibc-2.4
>=sys-devel/gcc-4.3.0
- !amd64? (
- gnome-base/libglade
- )
- amd64? (
- app-emulation/emul-linux-x86-gtklibs
- )"
+ gnome-base/libglade[${MULTILIB_USEDEP}]"
S="${WORKDIR}"
-d="${GAMES_PREFIX_OPT}/${PN}"
+d="/opt/${PN}"
QA_TEXTRELS_x86="`echo ${d#/}/lib32/lib{avcodec.so.51,avformat.so.52,avutil.so.49,FLAC.so.8}`"
QA_TEXTRELS_amd64="${QA_TEXTRELS_x86}"
@@ -39,7 +33,7 @@ pkg_nofetch() {
src_unpack() {
# manually run unzip as the initial seek causes it to exit(1)
- unpack_zip "${A}"
+ unpack_zip ${A}
rm lib*/lib{gcc_s,m,rt,selinux}.so.?
}
@@ -51,7 +45,7 @@ src_install() {
bb="survivor-${b}"
exeinto ${d}
newexe ${bb} ${bb} || die
- games_make_wrapper ${bb} "./${bb}" "${d}" || die
+ make_wrapper ${bb} "./${bb}" "${d}" || die
make_desktop_entry ${bb} "Shadowgrounds Survivor ${b}" "Shadowgrounds Survivor"
done
@@ -60,6 +54,4 @@ src_install() {
insinto ${d}
doins -r Config data Profiles *.fbz *.glade *-logo.png || die
-
- prepgamesdirs
}