aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog5
-rw-r--r--NEWS3
-rw-r--r--libs/default.eselect.in5
3 files changed, 11 insertions, 2 deletions
diff --git a/ChangeLog b/ChangeLog
index 8eb3fc8..18af066 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@
+2011-09-18 Ulrich Mueller <ulm@gentoo.org>
+
+ * libs/default.eselect.in (show_usage_message): Don't set IFS when
+ calling describe_*_options. Fixes bug 382693.
+
2011-09-04 Ulrich Mueller <ulm@gentoo.org>
* configure.ac: Update version to 1.2.17.
diff --git a/NEWS b/NEWS
index 0066b0c..02c3b5c 100644
--- a/NEWS
+++ b/NEWS
@@ -1,6 +1,9 @@
This file contains a summary of changes in released versions. Please read the
ChangeLog file for a more detailed listing of changes/bug fixes.
+ Bug fixes:
+ - Fixed bug #382693: IFS handling in default usage action.
+
New features:
- The profile module supports profiles in overlays (bug #265264).
diff --git a/libs/default.eselect.in b/libs/default.eselect.in
index 6fbe20e..4e3c98e 100644
--- a/libs/default.eselect.in
+++ b/libs/default.eselect.in
@@ -53,7 +53,7 @@ show_usage_message() {
continue
;;
?*)
- local desc="" ifs_save="${IFS}" action_text line
+ local desc="" ifs_save="${IFS}" action_text line options
is_function "describe_${action}" && desc=$(describe_${action})
if is_function "describe_${action}_parameters"; then
@@ -65,8 +65,9 @@ show_usage_message() {
write_kv_list_entry "${action_text}" "${desc:-(no description)}"
if is_function "describe_${action}_options"; then
+ options=$(describe_${action}_options)
IFS=$'\n'
- for line in $(describe_${action}_options); do
+ for line in ${options}; do
write_kv_list_entry -p \
" ${line%%*( ):*}" \
" ${line##+([^:]):*( )}"