summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <michael@orlitzky.com>2017-07-19 09:55:54 -0400
committerMichael Orlitzky <michael@orlitzky.com>2017-07-19 09:55:54 -0400
commit8cfe3c367df66bcb27cab3868190de3a18538fff (patch)
tree82f6357053096f2c04638132fc4fd8490d28e805
parentAdd .gitignore (diff)
downloadeselect-php-8cfe3c367df66bcb27cab3868190de3a18538fff.tar.gz
eselect-php-8cfe3c367df66bcb27cab3868190de3a18538fff.tar.bz2
eselect-php-8cfe3c367df66bcb27cab3868190de3a18538fff.zip
php-fpm.example.init.in: use @SYSCONFDIR@ from autotools.
-rw-r--r--Makefile.am9
-rw-r--r--doc/php-fpm.example.init.in2
2 files changed, 6 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 578062e..eb3b89b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,19 +12,20 @@ if APACHE2
nodist_apacheconf_DATA = $(srcdir)/src/70_mod_php.conf
endif
-# The next few rules allow us to replace bindir, libdir, and
-# localstatedir within our script and conf file. The example is taken
+# The next few rules allow us to replace bindir, libdir, etc.
+# within our script and conf file. The example is taken
# from the autoconf documentation and can be found in the
# "Installation Directory Variables" section.
edit = sed -e 's|@BINDIR[@]|$(bindir)|g' \
-e 's|@LIBDIR[@]|$(libdir)|g' \
- -e 's|@LOCALSTATEDIR[@]|$(localstatedir)|g'
+ -e 's|@LOCALSTATEDIR[@]|$(localstatedir)|g' \
+ -e 's|@SYSCONFDIR[@]|$(sysconfdir)|g'
$(nodist_eselect_DATA) $(nodist_apacheconf_DATA) $(nodist_init_DATA): Makefile
rm -f $@ $@.tmp
srcdir=''; \
test -f ./$@.in || srcdir=$(srcdir)/; \
- $(edit) $${srcdir}$@.in > $@.tmp
+ $(edit) $${srcdir}$@.in > $@.tmp
mv $@.tmp $@
$(srcdir)/src/php.eselect: $(srcdir)/src/php.eselect.in
diff --git a/doc/php-fpm.example.init.in b/doc/php-fpm.example.init.in
index 7969b71..912a5d8 100644
--- a/doc/php-fpm.example.init.in
+++ b/doc/php-fpm.example.init.in
@@ -11,7 +11,7 @@ set_phpvars() {
PHP_FPM_PID="/run/php-fpm.pid"
fi
- PHP_FPM_CONF="/etc/php/fpm-${PHPSLOT}/php-fpm.conf"
+ PHP_FPM_CONF="@SYSCONFDIR@/php/fpm-${PHPSLOT}/php-fpm.conf"
PHP_FPM_BIN="@LIBDIR@/${PHPSLOT}/bin/php-fpm"
}