summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2010-12-03 19:30:38 +0000
committerThomas Sachau <tommy@gentoo.org>2010-12-03 19:30:38 +0000
commit66ad500e8fac3298816737d2466ff32015ae036c (patch)
treed46e0fa1048bf95cb1c3f623b98682002ce991a8 /x11-libs
parentUpdate live ebuild (diff)
downloadenlightenment-66ad500e8fac3298816737d2466ff32015ae036c.tar.gz
enlightenment-66ad500e8fac3298816737d2466ff32015ae036c.tar.bz2
enlightenment-66ad500e8fac3298816737d2466ff32015ae036c.zip
Update live ebuild
(Portage version: 2.2.0_alpha6-r1/svn/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/elementary/elementary-0.7.0.52995.ebuild2
-rw-r--r--x11-libs/elementary/elementary-9999.ebuild31
-rw-r--r--x11-libs/elementary/metadata.xml17
3 files changed, 46 insertions, 4 deletions
diff --git a/x11-libs/elementary/elementary-0.7.0.52995.ebuild b/x11-libs/elementary/elementary-0.7.0.52995.ebuild
index 2c64118..f61779a 100644
--- a/x11-libs/elementary/elementary-0.7.0.52995.ebuild
+++ b/x11-libs/elementary/elementary-0.7.0.52995.ebuild
@@ -8,6 +8,8 @@ inherit enlightenment
DESCRIPTION="Basic widget set, based on EFL for mobile touch-screen devices."
KEYWORDS="~amd64 ~x86"
+IUSE=""
+
DEPEND=">=media-libs/edje-1.0.0_beta
>=dev-libs/ecore-1.0.0_beta
>=media-libs/evas-1.0.0_beta"
diff --git a/x11-libs/elementary/elementary-9999.ebuild b/x11-libs/elementary/elementary-9999.ebuild
index de7ae45..4d683a9 100644
--- a/x11-libs/elementary/elementary-9999.ebuild
+++ b/x11-libs/elementary/elementary-9999.ebuild
@@ -2,12 +2,35 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI=2
ESVN_SUB_PROJECT="TMP/st"
+
inherit enlightenment
DESCRIPTION="Basic widget set, based on EFL for mobile touch-screen devices."
+HOMEPAGE="http://trac.enlightenment.org/e/wiki/Elementary"
+LICENSE="LGPL-2.1"
+
+IUSE="dbus fbcon sdl thumbnails weather X xdg static-libs"
+
+DEPEND="
+ >=dev-libs/ecore-9999[evas,fbcon?,sdl?,X?]
+ >=media-libs/evas-9999[fbcon?,sdl?,X?]
+ >=media-libs/edje-9999
+ dbus? ( >=dev-libs/e_dbus-9999 )
+ xdg? ( >=dev-libs/efreet-9999 )
+ weather? ( >=net-libs/libeweather-9999 )
+ thumbnails? ( >=media-libs/ethumb-9999[dbus?] )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ MY_ECONF="$(use_enable dbus edbus)
+ $(use_enable fbcon ecore-fb)
+ $(use_enable sdl ecore-sdl)
+ $(use_enable thumbnails ethumb)
+ $(use_enable weather eweather)
+ $(use_enable X ecore-x)
+ $(use_enable xdg efreet)"
-DEPEND=">=dev-libs/ecore-9999
- >=media-libs/evas-9999
- >=media-libs/edje-9999"
-RDEPEND=${DEPEND}
+ enlightenment_src_configure
+}
diff --git a/x11-libs/elementary/metadata.xml b/x11-libs/elementary/metadata.xml
index 832c5fc..41d9a6b 100644
--- a/x11-libs/elementary/metadata.xml
+++ b/x11-libs/elementary/metadata.xml
@@ -5,4 +5,21 @@
<maintainer>
<email>enlightenment@gentoo.org</email>
</maintainer>
+<use>
+ <flag name="dbus">Enable integration with <pkg>dev-libs/e_dbus</pkg>.</flag>
+ <flag name="xdg">Enable integration with <pkg>dev-libs/efreet</pkg> for cross-desktop standards (freedesktop.org).</flag>
+ <flag name="weather">Enable integration with <pkg>net-libs/libeweather</pkg> to provide weather widget.</flag>
+ <flag name="thumbnails">Enable integration with <pkg>media-libs/ethumb</pkg> to generate and show thumbnails automatically.</flag>
+</use>
+<longdescription>
+Elementary is a widget set. It is a new-style of widget set much more
+canvas object based than anything else. Why not ETK? Why not EWL? Well
+they both tend to veer away from the core of Evas, Ecore and Edje a
+lot to build their own worlds. Also I wanted something focused on
+embedded devices - specifically small touchscreens. Unlike GTK+ and
+Qt, 75% of the "widget set" is already embodied in a common core -
+Ecore, Edje, Evas etc. So this fine-grained library splitting means
+all of this is shared, just a new widget "personality" is on top. And
+that is... Elementary, my dear watson. Elementary.
+</longdescription>
</pkgmetadata>