aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/ewl')
-rw-r--r--x11-libs/ewl/Manifest1
-rw-r--r--x11-libs/ewl/ewl-20090313.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/x11-libs/ewl/Manifest b/x11-libs/ewl/Manifest
index d0f344d..cab1935 100644
--- a/x11-libs/ewl/Manifest
+++ b/x11-libs/ewl/Manifest
@@ -1 +1,2 @@
EBUILD ewl-20090212.ebuild 1239 RMD160 ad9fef05270a0483e91fd0d31e163f4c099a98b4 SHA1 d25d098252efbfb1887d54860cb7b7acc62adbc4 SHA256 6cbc57a4ccdb887da41f4879b7e9730e40acc6953d0d73c48ee769673a5e1541
+EBUILD ewl-20090313.ebuild 1239 RMD160 ad9fef05270a0483e91fd0d31e163f4c099a98b4 SHA1 d25d098252efbfb1887d54860cb7b7acc62adbc4 SHA256 6cbc57a4ccdb887da41f4879b7e9730e40acc6953d0d73c48ee769673a5e1541
diff --git a/x11-libs/ewl/ewl-20090313.ebuild b/x11-libs/ewl/ewl-20090313.ebuild
new file mode 100644
index 0000000..06f3532
--- /dev/null
+++ b/x11-libs/ewl/ewl-20090313.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit enlightenment
+
+DESCRIPTION="The Enlightenment ewl library."
+HOMEPAGE="http://enlightenment.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm ~x86 ~amd64"
+IUSE="X xcb sdl fbcon opengl"
+
+RDEPEND="
+ X? ( x11-libs/libXrender )
+ xcb? ( x11-misc/xcb )
+ sdl? ( media-libs/libsdl )
+ opengl? ( virtual/opengl )
+ =media-libs/emotion-${PVR}
+ =media-libs/epsilon-${PVR}"
+
+DEPEND=">=dev-util/pkgconfig-0.9.0"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf}
+ $(use_enable X software-x11) \
+ $(use_enable X software-16-x11) \
+ $(use_enable xcb software-xcb) \
+ $(use_enable sdl software-sdl) \
+ $(use_enable fbcon fb) \
+ $(use_enable opengl opengl-glew) \
+ $(use_enable opengl opengl-x11) \
+ $(use_enable X xrender-x11) \
+ --enable-software-buffer \
+ --x-includes=${SYSROOT}/usr/X11R6/include \
+ --x-libraries=${SYSROOT}/usr/X11R6/lib"
+
+
+ econf ${myconf} || die "Configuration failed"
+ emake || die "Make failed"
+}