aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/parted/parted-2.2.ebuild')
-rw-r--r--sys-apps/parted/parted-2.2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/parted/parted-2.2.ebuild b/sys-apps/parted/parted-2.2.ebuild
new file mode 100644
index 0000000..df833b2
--- /dev/null
+++ b/sys-apps/parted/parted-2.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-2.2.ebuild,v 1.1 2010/02/26 15:46:20 jer Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
+HOMEPAGE="http://www.gnu.org/software/parted"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls readline +debug selinux device-mapper"
+
+# specific version for gettext needed
+# to fix bug 85999
+DEPEND=">=sys-fs/e2fsprogs-1.27
+ >=sys-libs/ncurses-5.2
+ nls? ( >=sys-devel/gettext-0.12.1-r2 )
+ readline? ( >=sys-libs/readline-5.2 )
+ selinux? ( sys-libs/libselinux )
+ device-mapper? ( || (
+ >=sys-fs/lvm2-2.02.45
+ sys-fs/device-mapper )
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/parted-1.9.0-cross-compile.patch"
+}
+
+src_configure() {
+ econf \
+ $(use_with readline) \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_enable selinux) \
+ $(use_enable device-mapper) \
+ --disable-rpath \
+ --disable-Werror || die "Configure failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Install failed"
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
+ dodoc doc/{API,FAT,USER.jp}
+}