aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/vim/files')
-rw-r--r--app-editors/vim/files/vim-7.1-interix-link.patch16
-rw-r--r--app-editors/vim/files/vim-7.1.285-darwin-x11link.patch11
-rw-r--r--app-editors/vim/files/vim-7.1.319-interix-cflags.patch23
-rw-r--r--app-editors/vim/files/vim-completion36
-rw-r--r--app-editors/vim/files/vim-cross-uint32.patch11
-rw-r--r--app-editors/vim/files/vimrc93
6 files changed, 190 insertions, 0 deletions
diff --git a/app-editors/vim/files/vim-7.1-interix-link.patch b/app-editors/vim/files/vim-7.1-interix-link.patch
new file mode 100644
index 0000000..da04666
--- /dev/null
+++ b/app-editors/vim/files/vim-7.1-interix-link.patch
@@ -0,0 +1,16 @@
+Interix 3.5 does link fine with some libraries removed from the link
+line (who knows why), but executing vim failes with unresolved
+references to things like _dlclose, _iconv and such...
+
+diff -ru vim71.orig/src/link.sh vim71/src/link.sh
+--- vim71.orig/src/link.sh Wed Feb 27 15:29:29 2008
++++ vim71/src/link.sh Wed Feb 27 15:32:07 2008
+@@ -41,7 +41,7 @@
+ if sh link.cmd; then
+ touch auto/link.sed
+ cp link.cmd linkit.sh
+- for libname in SM ICE nsl dnet dnet_stub inet socket dir elf iconv Xt Xmu Xp Xpm X11 Xdmcp x w dl pthread thread readline m perl crypt attr; do
++ for libname in dummy; do
+ cont=yes
+ while test -n "$cont"; do
+ if grep "l$libname " linkit.sh >/dev/null; then
diff --git a/app-editors/vim/files/vim-7.1.285-darwin-x11link.patch b/app-editors/vim/files/vim-7.1.285-darwin-x11link.patch
new file mode 100644
index 0000000..1cf00d6
--- /dev/null
+++ b/app-editors/vim/files/vim-7.1.285-darwin-x11link.patch
@@ -0,0 +1,11 @@
+--- src/configure.in
++++ src/configure.in
+@@ -2701,7 +2701,7 @@
+ AC_MSG_CHECKING(whether X_LOCALE needed)
+ AC_TRY_COMPILE([#include <X11/Xlocale.h>],,
+ AC_TRY_LINK_FUNC([_Xsetlocale], [AC_MSG_RESULT(yes)
+- AC_DEFINE(X_LOCALE)], AC_MSG_RESULT(no)),
++ AC_DEFINE(X_LOCALE) ldflags_save="$ldflags_save -lX11"], AC_MSG_RESULT(no)),
+ AC_MSG_RESULT(no))
+ fi
+ CFLAGS=$cflags_save
diff --git a/app-editors/vim/files/vim-7.1.319-interix-cflags.patch b/app-editors/vim/files/vim-7.1.319-interix-cflags.patch
new file mode 100644
index 0000000..630e001
--- /dev/null
+++ b/app-editors/vim/files/vim-7.1.319-interix-cflags.patch
@@ -0,0 +1,23 @@
+diff -ru vim71.orig/src/Makefile vim71/src/Makefile
+--- vim71.orig/src/Makefile 2008-07-16 08:29:55 +0200
++++ vim71/src/Makefile 2008-07-16 08:53:44 +0200
+@@ -1282,10 +1282,6 @@
+
+ ALL_CFLAGS = $(PRE_DEFS) $(CFLAGS) $(PROFILE_CFLAGS) $(POST_DEFS)
+
+-# Exclude $CFLAGS for osdef.sh, for Mac 10.4 some flags don't work together
+-# with "-E".
+-OSDEF_CFLAGS = $(PRE_DEFS) $(POST_DEFS)
+-
+ LINT_CFLAGS = -DLINT -I. $(PRE_DEFS) $(POST_DEFS) -Dinline= -D__extension__= -Dalloca=alloca
+
+ LINT_EXTRA = -DUSE_SNIFF -DHANGUL_INPUT -D"__attribute__(x)="
+@@ -2273,7 +2269,7 @@
+ $(PERLLIB)/ExtUtils/typemap if_perl.xs >> $@
+
+ auto/osdef.h: auto/config.h osdef.sh osdef1.h.in osdef2.h.in
+- CC="$(CC) $(OSDEF_CFLAGS)" srcdir=$(srcdir) sh $(srcdir)/osdef.sh
++ CC="$(CC) $(CFLAGS)" srcdir=$(srcdir) sh $(srcdir)/osdef.sh
+
+ QUOTESED = sed -e 's/[\\"]/\\&/g' -e 's/\\"/"/' -e 's/\\";$$/";/'
+ auto/pathdef.c: Makefile auto/config.mk
diff --git a/app-editors/vim/files/vim-completion b/app-editors/vim/files/vim-completion
new file mode 100644
index 0000000..157b546
--- /dev/null
+++ b/app-editors/vim/files/vim-completion
@@ -0,0 +1,36 @@
+# Author: Ciaran McCreesh <ciaranm@gentoo.org>
+#
+# completion for vim
+
+_vim()
+{
+ local cur prev cmd args
+
+ COMPREPLY=()
+ cur=${COMP_WORDS[COMP_CWORD]}
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+ cmd=${COMP_WORDS[0]}
+
+ if [[ "${prev}" == "--servername" ]] ; then
+ local servers
+ servers=$(gvim --serverlist )
+ COMPREPLY=( $( compgen -W "${servers}" -- $cur ) )
+
+ elif [[ "${prev}" == -[uUi] ]] ; then
+ COMPREPLY=( $( compgen -W "NONE" ) \
+ $( compgen -f -X "!*vim*" -- "$cur" ) )
+
+ elif [[ "${cur}" == -* ]] ; then
+ args='-t -q -c -S --cmd -A -b -C -d -D -e -E -f --nofork \
+ -F -g -h -H -i -L -l -m -M -N -n -nb -o -R -r -s \
+ -T -u -U -V -v -w -W -x -X -y -Y -Z --echo-wid \
+ --help --literal --noplugin --version'
+ COMPREPLY=( $( compgen -W "${args}" -- $cur ) )
+ else
+ _filedir
+ fi
+}
+
+complete -o filenames -F _vim vim ex view evim rvim rview
+
+# vim: set ft=sh sw=4 et sts=4 :
diff --git a/app-editors/vim/files/vim-cross-uint32.patch b/app-editors/vim/files/vim-cross-uint32.patch
new file mode 100644
index 0000000..9849389
--- /dev/null
+++ b/app-editors/vim/files/vim-cross-uint32.patch
@@ -0,0 +1,11 @@
+--- vim73/src/configure.in
++++ vim73/src/configure.in
+@@ -3180,7 +3180,7 @@
+ }],
+ AC_MSG_RESULT(ok),
+ AC_MSG_ERROR([WRONG! uint32_t not defined correctly.]),
+-AC_MSG_ERROR([could not compile program using uint32_t.]))
++AC_MSG_WARN([could not check when cross-compiling]))
+
+ dnl Check for memmove() before bcopy(), makes memmove() be used when both are
+ dnl present, fixes problem with incompatibility between Solaris 2.4 and 2.5.
diff --git a/app-editors/vim/files/vimrc b/app-editors/vim/files/vimrc
new file mode 100644
index 0000000..2038d96
--- /dev/null
+++ b/app-editors/vim/files/vimrc
@@ -0,0 +1,93 @@
+" Default configuration file for Vim
+" Written by Aron Griffis <agriffis@gentoo.org>
+" Modified by Ryan Phillips <rphillips@gentoo.org>
+" Added Redhat's vimrc info by Seemant Kulleen <seemant@gentoo.org>
+
+" The following are some sensible defaults for Vim for most users.
+" We attempt to change as little as possible from Vim's defaults,
+" deviating only where it makes sense
+set nocompatible " Use Vim defaults (much better!)
+set bs=2 " Allow backspacing over everything in insert mode
+set ai " Always set auto-indenting on
+"set backup " Keep a backup file
+set viminfo='20,\"50 " read/write a .viminfo file -- limit to only 50
+set history=50 " keep 50 lines of command history
+set ruler " Show the cursor position all the time
+
+
+" Added to default to high security within Gentoo. Fixes bug #14088
+set modelines=0
+
+if v:lang =~ "^ko"
+ set fileencodings=euc-kr
+ set guifontset=-*-*-medium-r-normal--16-*-*-*-*-*-*-*
+elseif v:lang =~ "^ja_JP"
+ set fileencodings=euc-jp
+ set guifontset=-misc-fixed-medium-r-normal--14-*-*-*-*-*-*-*
+elseif v:lang =~ "^zh_TW"
+ set fileencodings=big5
+ set guifontset=-sony-fixed-medium-r-normal--16-150-75-75-c-80-iso8859-1,-taipei-fixed-medium-r-normal--16-150-75-75-c-160-big5-0
+elseif v:lang =~ "^zh_CN"
+ set fileencodings=gb2312
+ set guifontset=*-r-*
+endif
+if v:lang =~ "utf8$" || v:lang =~ "UTF-8$"
+ set fileencodings=utf-8,latin1
+endif
+
+" Only do this part when compiled with support for autocommands
+if has("autocmd")
+ " In text files, always limit the width of text to 78 characters
+ autocmd BufRead *.txt set tw=78
+ " When editing a file, always jump to the last cursor position
+ autocmd BufReadPost *
+ \ if line("'\"") > 0 && line ("'\"") <= line("$") |
+ \ exe "normal g'\"" |
+ \ endif
+endif
+
+" Don't use Ex mode, use Q for formatting
+map Q gq
+
+" Switch syntax highlighting on, when the terminal has colors
+" Also switch on highlighting the last used search pattern.
+if &t_Co > 2 || has("gui_running")
+ syntax on
+ set hlsearch
+endif
+
+if &term=="xterm"
+ set t_RV= " don't check terminal version
+ set t_Co=8
+ set t_Sb=^[4%dm
+ set t_Sf=^[3%dm
+endif
+
+if has("autocmd")
+
+" Gentoo-specific settings for ebuilds. These are the federally-mandated
+" required tab settings. See the following for more information:
+" http://www.gentoo.org/doc/en/xml/gentoo-howto.xml
+augroup gentoo
+ au!
+ au BufRead,BufNewFile *.ebuild set tabstop=4 shiftwidth=4 noexpandtab
+augroup END
+
+endif " has("autocmd")
+
+" some extra commands for HTML editing
+nmap ,mh wbgueyei<<ESC>ea></<ESC>pa><ESC>bba
+nmap ,h1 _i<h1><ESC>A</h1><ESC>
+nmap ,h2 _i<h2><ESC>A</h2><ESC>
+nmap ,h3 _i<h3><ESC>A</h3><ESC>
+nmap ,h4 _i<h4><ESC>A</h4><ESC>
+nmap ,h5 _i<h5><ESC>A</h5><ESC>
+nmap ,h6 _i<h6><ESC>A</h6><ESC>
+nmap ,hb wbi<b><ESC>ea</b><ESC>bb
+nmap ,he wbi<em><ESC>ea</em><ESC>bb
+nmap ,hi wbi<i><ESC>ea</i><ESC>bb
+nmap ,hu wbi<u><ESC>ea</i><ESC>bb
+nmap ,hs wbi<strong><ESC>ea</strong><ESC>bb
+nmap ,ht wbi<tt><ESC>ea</tt><ESC>bb
+nmap ,hx wbF<df>f<df>
+