aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaksim 'max_posedon' Melnikau <maxposedon@gmail.com>2010-05-16 19:29:29 +0300
committerMaksim 'max_posedon' Melnikau <maxposedon@gmail.com>2010-05-16 19:29:29 +0300
commit7cab638498591abdd22b0e602081a49d488daafb (patch)
tree5c4016eb97fce746363b54616b0475792f1b60be
parentforce -j1 for libfso-glib (diff)
downloadembedded-cross-7cab638498591abdd22b0e602081a49d488daafb.tar.gz
embedded-cross-7cab638498591abdd22b0e602081a49d488daafb.tar.bz2
embedded-cross-7cab638498591abdd22b0e602081a49d488daafb.zip
update gnutls-2.8.6 cross compilation fix
Signed-off-by: Maksim 'max_posedon' Melnikau <maxposedon@gmail.com>
-rw-r--r--net-libs/gnutls/Manifest4
-rw-r--r--net-libs/gnutls/gnutls-2.8.5.ebuild4
-rw-r--r--net-libs/gnutls/gnutls-2.8.6.ebuild108
3 files changed, 113 insertions, 3 deletions
diff --git a/net-libs/gnutls/Manifest b/net-libs/gnutls/Manifest
index d3008b2..f224563 100644
--- a/net-libs/gnutls/Manifest
+++ b/net-libs/gnutls/Manifest
@@ -1,3 +1,5 @@
AUX gnutls-2.8.0-cross-configure.patch 780 RMD160 f229962e0a877695632b6f880c96b025d1879568 SHA1 8ab2ef230afd775fe5c4a1aa20589d162e992094 SHA256 1b86008a72993fd2332a554831d5d191f4a5ced1c9cb8822eef56905d83b3d86
DIST gnutls-2.8.5.tar.bz2 6196862 RMD160 f160b8b413ae7e0b9243135fd8ffd0dd350d1504 SHA1 5121c52efd4718ad3d8b641d28343b0c6abaa571 SHA256 9249c29df71551e302e0186f4e1876dd6cc4c6cf2974b432c22525dde815cae8
-EBUILD gnutls-2.8.5.ebuild 2900 RMD160 e1a940bcd36012b0c5958a785a145b9c65530f50 SHA1 044b0ce40b0c5d34f757a7c9bcec104833cc3946 SHA256 55fb166136bc8c5051e8d274427dc39ab368bfd6d41dd17be3145e5a9d144214
+DIST gnutls-2.8.6.tar.bz2 6469369 RMD160 1cfda29a60df3b032b8b611e4341c2e834bb26b2 SHA1 bff911d4fd7389aa6698a644b3748eb2d23715bc SHA256 d6f846a7064af3ee2c9aebd65dcee76953b767170cbcd719e990ed6b9688a356
+EBUILD gnutls-2.8.5.ebuild 2879 RMD160 7dc9a371176eb9cfbcb7f5c97853075f5065b26b SHA1 54212b345a8e48741165a765932ef418f491aecd SHA256 95a913797e9ef45d69920d3a23267e1c5e7ddb63812f7c82e7f982c202b3ee00
+EBUILD gnutls-2.8.6.ebuild 2881 RMD160 1eec90896738a9b0fad35fc07b38146a5c244659 SHA1 1131c7a8181d8139627cd76d08aed6dc437b5603 SHA256 b63f6f868404f8c3572ae7c661fa24e3854854a660c3d5f3e5af6998a4ef3a41
diff --git a/net-libs/gnutls/gnutls-2.8.5.ebuild b/net-libs/gnutls/gnutls-2.8.5.ebuild
index dd74b26..c902e73 100644
--- a/net-libs/gnutls/gnutls-2.8.5.ebuild
+++ b/net-libs/gnutls/gnutls-2.8.5.ebuild
@@ -55,7 +55,7 @@ src_prepare() {
sed -e 's/imagesdir = $(infodir)/imagesdir = $(htmldir)/' -i doc/Makefile.am
# Make gnutls cross-compile by removing the libdir from the search path
- epatch "${FILESDIR}/${PN}-2.8.0-cross-configure.patch"
+ epatch "${FILESDIR}/${PN}-2.8.0-cross-configure.patch"
local dir
for dir in m4 lib/m4 libextra/m4; do
@@ -79,7 +79,7 @@ src_configure() {
# For cross-compilation we need to research the library parts.
if tc-is-cross-compiler ; then
myconf="${myconf} \
- --without-libgcrypt-prefix \
+ --without-libgcrypt-prefix \
--without-libtasn1-prefix \
--without-libreadline-prefix"
fi
diff --git a/net-libs/gnutls/gnutls-2.8.6.ebuild b/net-libs/gnutls/gnutls-2.8.6.ebuild
new file mode 100644
index 0000000..3500de3
--- /dev/null
+++ b/net-libs/gnutls/gnutls-2.8.6.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.8.6.ebuild,v 1.1 2010/03/18 17:02:25 arfrever Exp $
+
+EAPI="3"
+
+inherit autotools libtool
+
+DESCRIPTION="A TLS 1.0 and SSL 3.0 implementation for the GNU project"
+HOMEPAGE="http://www.gnutls.org/"
+
+if [[ "${PV}" == *pre* ]]; then
+ SRC_URI="http://daily.josefsson.org/${P%.*}/${P%.*}-${PV#*pre}.tar.gz"
+else
+ MINOR_VERSION="${PV#*.}"
+ MINOR_VERSION="${MINOR_VERSION%.*}"
+ if [[ $((MINOR_VERSION % 2)) == 0 ]]; then
+ #SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+ else
+ SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.bz2"
+ fi
+ unset MINOR_VERSION
+fi
+
+# GPL-3 for the gnutls-extras library and LGPL for the gnutls library.
+LICENSE="LGPL-2.1 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="bindist +cxx doc examples guile lzo nls zlib"
+
+RDEPEND="dev-libs/libgpg-error
+ >=dev-libs/libgcrypt-1.4.0
+ >=dev-libs/libtasn1-0.3.4
+ nls? ( virtual/libintl )
+ guile? ( dev-scheme/guile[networking] )
+ zlib? ( >=sys-libs/zlib-1.1 )
+ !bindist? ( lzo? ( >=dev-libs/lzo-2 ) )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ doc? ( dev-util/gtk-doc )
+ nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}/${P%_pre*}"
+
+pkg_setup() {
+ if use lzo && use bindist; then
+ ewarn "lzo support was disabled for binary distribution of GnuTLS"
+ ewarn "due to licensing issues. See Bug #202381 for details."
+ fi
+}
+
+src_prepare() {
+ sed -e 's/imagesdir = $(infodir)/imagesdir = $(htmldir)/' -i doc/Makefile.am
+
+ # Make gnutls cross-compile by removing the libdir from the search path
+ epatch "${FILESDIR}/${PN}-2.8.0-cross-configure.patch"
+
+ local dir
+ for dir in m4 lib/m4 libextra/m4; do
+ rm -f "${dir}/lt"* "${dir}/libtool.m4"
+ done
+ find . -name ltmain.sh -exec rm {} \;
+ for dir in . lib libextra; do
+ pushd "${dir}" > /dev/null
+ eautoreconf
+ popd > /dev/null
+ done
+
+ elibtoolize # for sane .so versioning on FreeBSD
+}
+
+src_configure() {
+ local myconf
+ use bindist && myconf="--without-lzo" || myconf="$(use_with lzo)"
+
+ # For cross-compilation we need to research the library parts.
+ if tc-is-cross-compiler ; then
+ myconf="${myconf} \
+ --without-libgcrypt-prefix \
+ --without-libtasn1-prefix \
+ --without-libreadline-prefix"
+ fi
+
+ econf --htmldir=/usr/share/doc/${P}/html \
+ $(use_enable cxx) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable guile) \
+ $(use_enable nls) \
+ $(use_with zlib) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS doc/TODO
+
+ if use doc; then
+ dodoc doc/gnutls.{pdf,ps}
+ dohtml doc/gnutls.html
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc doc/examples/*.c
+ fi
+}