summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run.sh')
-rwxr-xr-xtests/run.sh31
1 files changed, 31 insertions, 0 deletions
diff --git a/tests/run.sh b/tests/run.sh
new file mode 100755
index 0000000..5424085
--- /dev/null
+++ b/tests/run.sh
@@ -0,0 +1,31 @@
+#!/bin/bash
+# Copyright 1999-2021 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Run eltpatch against copies of libtool for quick testing.
+
+set -e
+cd "$(dirname "$(realpath "$0")")"
+
+export LD=ld
+export CHOST=x86_64-gentoo-linux-gnu
+export ELT_patchdir="${PWD}/../patches"
+eltpatch=${PWD}/../eltpatch
+
+test() {
+ local PV="$1"
+
+ rm -rf "${PV}.tmp"
+ cp -a "${PV}" "${PV}.tmp"
+ export S="${PWD}/${PV}.tmp"
+ export TMPDIR=${S}
+ "${eltpatch}"
+}
+
+mkdir -p libtools
+for f in *.*/configure.ac ; do
+ v=${f%/*}
+ [[ ${v} == *.tmp ]] && continue
+ echo "### ${v}"
+ test "${v}"
+done