aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-10-27 12:22:01 +0200
committerUlrich Müller <ulm@gentoo.org>2023-10-30 17:21:14 +0100
commit2556659c7a76dd00176efd7892e02ca0130998e2 (patch)
tree6bbbde24e64ac2395033b8a1c1cda8a3e3f7aa58 /general-concepts
parentdevbook.xsl: Warn about missing terminating slash in internal links (diff)
downloaddevmanual-2556659c7a76dd00176efd7892e02ca0130998e2.tar.gz
devmanual-2556659c7a76dd00176efd7892e02ca0130998e2.tar.bz2
devmanual-2556659c7a76dd00176efd7892e02ca0130998e2.zip
Fix internal links
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'general-concepts')
-rw-r--r--general-concepts/autotools/text.xml13
-rw-r--r--general-concepts/dependencies/text.xml6
-rw-r--r--general-concepts/ebuild-revisions/text.xml8
-rw-r--r--general-concepts/mirrors/text.xml7
-rw-r--r--general-concepts/projects/text.xml2
-rw-r--r--general-concepts/slotting/text.xml4
-rw-r--r--general-concepts/tree/text.xml2
7 files changed, 22 insertions, 20 deletions
diff --git a/general-concepts/autotools/text.xml b/general-concepts/autotools/text.xml
index 885fbd6..09162ff 100644
--- a/general-concepts/autotools/text.xml
+++ b/general-concepts/autotools/text.xml
@@ -5,8 +5,9 @@
<body>
<todo>
-This is too long for <uri link="::general-concepts"/>. It needs to be split up and
-moved somewhere, either to a top-level of its own or into <uri link="::appendices/"/>.
+This is too long for <uri link="::general-concepts/"/>. It needs to be split up
+and moved somewhere, either to a top-level of its own or into
+<uri link="::appendices/"/>.
</todo>
<p>
@@ -495,10 +496,10 @@ This is handled via the macro <c>AC_SUBST(VARNAME)</c> in <c>configure.ac</c>.
<p>
Sometimes, badly behaved <c>Makefile.am</c> files will override user variables such
as <c>CFLAGS</c>. This must not be allowed <d/> see
-<uri link="::general-concepts/user-environment#Not Filtering Variables"/>. There
-are separate special variables which should be used in these situations <d/> for
-setting <c>CFLAGS</c>. for example, a <c>Makefile.am</c> should use <c>AM_CFLAGS</c> so
-that user preferences are not ignored.
+<uri link="::general-concepts/user-environment/#Not Filtering Variables"/>.
+There are separate special variables which should be used in these situations
+<d/> for setting <c>CFLAGS</c>. for example, a <c>Makefile.am</c> should use
+<c>AM_CFLAGS</c> so that user preferences are not ignored.
</p>
<p>
diff --git a/general-concepts/dependencies/text.xml b/general-concepts/dependencies/text.xml
index b041444..98a84d1 100644
--- a/general-concepts/dependencies/text.xml
+++ b/general-concepts/dependencies/text.xml
@@ -19,7 +19,7 @@ them if you're not sure.
<p>
Please also see the following section on
-<uri link="::general-concepts/ebuild-revisions"/>
+<uri link="::general-concepts/ebuild-revisions/"/>
for how dependencies and revisions interact.
</p>
@@ -74,7 +74,7 @@ distinctions still apply even if it isn't, strictly speaking, cross-compiling.
<p>
Build dependencies are used to specify any dependencies that are required
to unpack, patch, compile, test or install the package (but see
-<uri link="::general-concepts/dependencies#Implicit System Dependency"/> for
+<uri link="::general-concepts/dependencies/#Implicit System Dependency"/> for
exemptions).
</p>
@@ -382,7 +382,7 @@ DEPEND="qt5? ( ~dev-qt/qtcore-5.15.2:5 )
In <c>EAPI=5</c> and higher, you can use slot operators appended to the package
name to declare whether or not your package should be rebuilt after the versions
satisfying its runtime dependencies are updated to versions with a different slot
-or <uri link="::general-concepts/slotting#Sub-Slots">sub-slot</uri>:
+or <uri link="::general-concepts/slotting/#Sub-Slots">sub-slot</uri>:
</p>
<ul>
diff --git a/general-concepts/ebuild-revisions/text.xml b/general-concepts/ebuild-revisions/text.xml
index b524a4b..8248a6e 100644
--- a/general-concepts/ebuild-revisions/text.xml
+++ b/general-concepts/ebuild-revisions/text.xml
@@ -6,9 +6,9 @@
<body>
<p>
Ebuilds may have a Gentoo revision number associated with them. This is a
-<c>-rX</c> suffix, where <c>X</c> is an integer <d/> see <uri
-link="::ebuild-writing/file-format#File Naming Rules"/>. This
-component must only be used for Gentoo changes, not upstream releases.
+<c>-rX</c> suffix, where <c>X</c> is an integer <d/> see
+<uri link="::ebuild-writing/file-format/#File Naming Rules"/>.
+This component must only be used for Gentoo changes, not upstream releases.
An ebuild with no explicit revision number has the implicit <c>-r0</c>
revision.
</p>
@@ -40,7 +40,7 @@ of thumb could be used as a guideline:
as such), then a new revision should be introduced and the old one
kept. If the package has stable keywords, the new revision should
be dropped to <c>~arch</c> (see
- <uri link="::keywording#Keywording on Upgrades"/>).
+ <uri link="::keywording/#Keywording on Upgrades"/>).
For any such revision bump, the new ebuild should be based
on the previous revision to ensure that fixes aren't dropped
accidentally.
diff --git a/general-concepts/mirrors/text.xml b/general-concepts/mirrors/text.xml
index f1ce1bb..f380d45 100644
--- a/general-concepts/mirrors/text.xml
+++ b/general-concepts/mirrors/text.xml
@@ -41,9 +41,10 @@ This should not be used in new ebuilds.
<p>
There is also <c>RESTRICT="fetch"</c>, which prevents Portage from trying to
-fetch anything manually. The <uri link="::ebuild-writing/functions/pkg_nofetch">
-pkg_nofetch</uri> function will be called if any <c>SRC_URI</c> components
-cannot be found. This should only be used if a license requires it.
+fetch anything manually.
+The <uri link="::ebuild-writing/functions/pkg_nofetch/">pkg_nofetch</uri>
+function will be called if any <c>SRC_URI</c> components cannot be found.
+This should only be used if a license requires it.
</p>
</body>
</subsection>
diff --git a/general-concepts/projects/text.xml b/general-concepts/projects/text.xml
index 43741d8..19188d4 100644
--- a/general-concepts/projects/text.xml
+++ b/general-concepts/projects/text.xml
@@ -21,7 +21,7 @@ form a project hierarchy.
<p>
A package maintained by a project needs to have the
project explicitly listed as a maintainer in its
-<uri link="::ebuild-writing/misc-files/metadata">metadata.xml</uri>.
+<uri link="::ebuild-writing/misc-files/metadata/">metadata.xml</uri>.
The full listing of all the projects can be found on
<uri link="https://api.gentoo.org/metastructure/projects.xml">
api.gentoo.org</uri> or on the
diff --git a/general-concepts/slotting/text.xml b/general-concepts/slotting/text.xml
index 05d01c9..9eabf08 100644
--- a/general-concepts/slotting/text.xml
+++ b/general-concepts/slotting/text.xml
@@ -41,7 +41,7 @@ possible that the user may have <c>foo-2.0</c> installed and no <c>foo-1.x</c> a
<p>
To <c>DEPEND</c> upon a package in a specific slot, refer to
-<uri link="::general-concepts/dependencies#SLOT Dependencies" />.
+<uri link="::general-concepts/dependencies/#SLOT Dependencies"/>.
</p>
</body>
@@ -55,7 +55,7 @@ but it's undesirable or inconvenient to allow some of these versions to be insta
simultaneously. In <c>EAPI=5</c> and higher, this situation can be handled by
using sub-slots, which are delimited from the regular slot by a <c>/</c> character,
as in <c>SLOT="slot/subslot"</c>. Packages can
-<uri link="::general-concepts/dependencies#Slot Operators">request to be
+<uri link="::general-concepts/dependencies/#Slot Operators">request to be
automatically rebuilt</uri> when the subslot of a runtime dependency changes.
</p>
diff --git a/general-concepts/tree/text.xml b/general-concepts/tree/text.xml
index 6c91eb4..9fb9cb9 100644
--- a/general-concepts/tree/text.xml
+++ b/general-concepts/tree/text.xml
@@ -41,7 +41,7 @@ The basic layout of the Gentoo repository is as follows:
Metadata directory, <c>metadata/</c>. Most of the listed contents
are not kept directly in the main git tree but instead
auto-generated or included from other repositories as part of the
- <uri link="::general-concepts/git-to-rsync">Git to Rsync</uri>
+ <uri link="::general-concepts/git-to-rsync/">Git to Rsync</uri>
process.
<ul>
<li>