aboutsummaryrefslogtreecommitdiff
path: root/TODO
diff options
context:
space:
mode:
authorEric Thibodeau <kyron@neuralbs.com>2008-08-18 01:24:04 -0400
committerEric Thibodeau <kyron@neuralbs.com>2008-08-18 01:24:04 -0400
commit11f730f49ef407d5c370f45fc1cea4d9f59d76ea (patch)
treeb0fd78fb24da3fa4b53d37fe1a3688514596af45 /TODO
parentAdded support for CPUSET (diff)
downloadclustering-livecd-11f730f49ef407d5c370f45fc1cea4d9f59d76ea.tar.gz
clustering-livecd-11f730f49ef407d5c370f45fc1cea4d9f59d76ea.tar.bz2
clustering-livecd-11f730f49ef407d5c370f45fc1cea4d9f59d76ea.zip
Multiple addition and cleanups
- added passwordless SSH for root to nodes - added some FAQs and documentation - quick update of the HOWTOs - switch to snapshot 20080816 - added torque (PBS) and underlying support modules - added a few config variables to scripts to ease future changes - created openrc-0.2.5-r1 to ease the NFSROOT howto procedure + (don't have to unpack and repack the snapshot for running ebuild * digest) * corrected invalide use of non existant functions.sh in nfsroot_setup.sh beowulf-head-0.1.ebuild: * Added the modules infrastructure to be called by dnsmasq's script callback interface * provided examples are for torque and c3. -- C3's configuration file is valid but doesn't seem to work (might be a python issue) -- torque is _still_ work in progress: + some of the setup seems to be incomplete (in the ebuild) + the profile switch was to get a better chance at a working installation (2.3.3) - Science overlay was added to pull in the modularized version of openmpi Since USE=pbs in the specs, openmpi requires Torque but Torque also require kernel (stage2). Torque is currently being built twise, once minimal for openmpi, then with kernel features in the stage2. Commenting out pbs and torque in stage2 reverts the build to a simple cluster without the whole PBS infrastructure...but it works ;)
Diffstat (limited to 'TODO')
-rw-r--r--TODO15
1 files changed, 15 insertions, 0 deletions
diff --git a/TODO b/TODO
new file mode 100644
index 0000000..17ac144
--- /dev/null
+++ b/TODO
@@ -0,0 +1,15 @@
+Code:
+
+cluster-setup
+
+* Separate the functions so that the node part could be called upon multiple NFSROOTs. This would make it easyer to provide support for different ARCHs provided by the same master. Something in the lines of `setup-nfsroot $NFSROOOT` would be appropriate.
+
+* Modify script so that it can be used under different ROOT environements (ie: USB environment where the ROOT is actually rw)
+- This wasnt done since one can argue that a USBkey install is identical to an HDD install and most of the automation in the cluster-setup are meant for a livecd. HDD and USBkey install should just use the ebuilds and follow the instructions.
+
+* Modularize so it is easy to add new features to auto-confgure, triggered by USE flags (ie: the torque auto-config is triggered bu the pbs USE flag)
+
+System:
+
+* Aufs mount the liveCD and provide the means by which one may save the config+environement to USB key (is it worth the effort or shouldn't someone just install directly to USB).
+