aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Neumann <leonardo@neumann.dev.br>2022-03-25 18:24:07 -0300
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-04-07 17:56:12 -0700
commit0b11ea374e0ae2434810e3671dc382ff5b468a14 (patch)
treeea04aff51a5cc20d5f07429b8bcb9eb574517598
parentCargo.toml: Dependency bump (diff)
downloadcargo-ebuild-0b11ea374e0ae2434810e3671dc382ff5b468a14.tar.gz
cargo-ebuild-0b11ea374e0ae2434810e3671dc382ff5b468a14.tar.bz2
cargo-ebuild-0b11ea374e0ae2434810e3671dc382ff5b468a14.zip
Cargo.toml: Add and enable vendored-libgit2 feature
Closes: gentoo#20 Signed-off-by: Leonardo Neumann <leonardo@neumann.dev.br> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--Cargo.toml9
1 files changed, 8 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a66ede1..4058bf8 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -29,13 +29,20 @@ cargo_metadata = "0.14.2"
itertools = "0.10.3"
rustsec = "0.25.1"
structopt = "0.3.26"
-serde = { version = "1.0.136", features = ["derive"] }
time = "0.3.9"
[dependencies.phf]
version = "0.10.1"
features = ["macros"]
+[dependencies.serde]
+version = "1.0.136"
+features = ["derive"]
+
[dependencies.tera]
version = "1.15.0"
default-features = false
+
+[features]
+default = ["vendored-libgit2"]
+vendored-libgit2 = ["rustsec/vendored-libgit2"]