aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheofilos Intzoglou <int.teo@gmail.com>2011-10-05 14:41:57 +0300
committerTheofilos Intzoglou <int.teo@gmail.com>2011-10-05 14:41:57 +0300
commitbe4f4e233b0e42bd7a19ddcea3f64924600dfc39 (patch)
treea142d5b4547c2b1769e64a3a61d498d575aa2aba
parentPort to CMake and add a check for the portage api. If the api is (diff)
downloadc-portage-be4f4e233b0e42bd7a19ddcea3f64924600dfc39.tar.gz
c-portage-be4f4e233b0e42bd7a19ddcea3f64924600dfc39.tar.bz2
c-portage-be4f4e233b0e42bd7a19ddcea3f64924600dfc39.zip
Rename project in CMakeLists.txt to c-portage instead of cportage
and add an install command to also install the header files to the system.
-rw-r--r--CMakeLists.txt7
-rw-r--r--src/CMakeLists.txt2
2 files changed, 6 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bfef33c..149d05d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,10 @@
-project(cportage)
+project(c-portage)
cmake_minimum_required(VERSION 2.8)
-set(CMAKE_MODULE_PATH ${cportage_SOURCE_DIR}/cmake)
+set(CMAKE_MODULE_PATH ${c-portage_SOURCE_DIR}/cmake)
find_package(PortageApi REQUIRED)
+install(DIRECTORY src/ DESTINATION include/c-portage
+ FILES_MATCHING PATTERN "*.h")
+
add_subdirectory(src)
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 7eb4403..571135b 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -2,4 +2,4 @@ find_package(PythonLibs REQUIRED)
include_directories(${PYTHON_INCLUDE_DIRS})
add_definitions(-std=c99)
-add_library(cportage dataconnect.c dict.c flag.c interpreter.c packageproperties.c portagesettings.c stringlist.c tester.c)
+add_library(c-portage dataconnect.c dict.c flag.c interpreter.c packageproperties.c portagesettings.c stringlist.c tester.c)