summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Böhm <bb@xnull.de>2010-07-19 13:08:49 +0200
committerBenedikt Böhm <bb@xnull.de>2010-07-19 13:08:49 +0200
commit081745f664d136ac6a00aceca0146f7674160fff (patch)
tree9bf87492473a3d2430272699ffefd69de03d1a4d /sys-apps
parentadd trac-accountmanager (diff)
downloadbetagarden-081745f664d136ac6a00aceca0146f7674160fff.tar.gz
betagarden-081745f664d136ac6a00aceca0146f7674160fff.tar.bz2
betagarden-081745f664d136ac6a00aceca0146f7674160fff.zip
add systemd ebuild (bug #318365, mostly copied from keruspe overlay)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/Manifest1
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/sys-apps/systemd/Manifest b/sys-apps/systemd/Manifest
new file mode 100644
index 0000000..e09b635
--- /dev/null
+++ b/sys-apps/systemd/Manifest
@@ -0,0 +1 @@
+EBUILD systemd-9999.ebuild 1389 RMD160 0f290cfead00619aa50238d080c5ecf0701733da SHA1 89d79d23706c25fbb08c86109ef9b9bd12058fcc SHA256 92da95188568b60f3239957d4361b132dd31528bac2e74157803fc6b24825573
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
new file mode 100644
index 0000000..6366402
--- /dev/null
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit autotools git
+
+DESCRIPTION="Replacement for sysvinit with extensive usage of parallelization"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
+EGIT_REPO_URI="git://anongit.freedesktop.org/systemd"
+EGIT_BRANCH="master"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk pam +tcpwrap"
+
+RDEPEND="
+ >=sys-apps/dbus-1.3.2
+ dev-libs/dbus-glib
+ >=sys-fs/udev-160
+ >=sys-kernel/linux-headers-2.6.32
+ sys-libs/libcap
+ gtk? ( >=x11-libs/gtk+-2.20 )
+ tcpwrap? ( sys-apps/tcp-wrappers )
+ pam? ( virtual/pam )
+ >=dev-lang/vala-0.8"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ app-text/build-docbook-catalog
+ dev-libs/libxslt"
+
+WANT_AUTOMAKE=1.11
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-distro=gentoo \
+ --prefix=/usr \
+ --with-rootdir=/ \
+ $(use_enable gtk) \
+ $(use_enable pam) \
+ $(use_enable tcpwrap)
+}
+
+src_install() {
+ # make sure all directory are created
+ dodir /cgroup/{cpu,cpuacct,cpuset,debug,devices,freezer,memory,ns,systemd}
+
+ emake DESTDIR="${D}" install
+
+ dodoc "${D}/usr/share/doc/systemd"/* && \
+ rm -r "${D}/usr/share/doc/systemd/"
+
+ cd ${D}/usr/share/man/man8/
+ for i in halt poweroff reboot runlevel shutdown telinit; do
+ mv ${i}.8 systemd.${i}.8
+ done
+}