summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-12-07 19:00:54 +0100
committerJustin Lecher <jlec@gentoo.org>2013-12-07 19:00:54 +0100
commitb762d49e112c1ce997265c72e1f975b11953fbdf (patch)
treeebdb7d5a2ac5e4ca25ee1e0a72789fb13bbe1163 /dev-vcs
parentdev-lang/opal: Fix hardcoded paths (diff)
downloadbetagarden-b762d49e112c1ce997265c72e1f975b11953fbdf.tar.gz
betagarden-b762d49e112c1ce997265c72e1f975b11953fbdf.tar.bz2
betagarden-b762d49e112c1ce997265c72e1f975b11953fbdf.zip
dev-vcs/hub: Add live ebuild
Package-Manager: portage-2.2.7
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/hub/ChangeLog23
-rw-r--r--dev-vcs/hub/hub-9999.ebuild37
-rw-r--r--dev-vcs/hub/metadata.xml11
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-vcs/hub/ChangeLog b/dev-vcs/hub/ChangeLog
new file mode 100644
index 0000000..4029631
--- /dev/null
+++ b/dev-vcs/hub/ChangeLog
@@ -0,0 +1,23 @@
+# ChangeLog for dev-vcs/hub
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hub/ChangeLog,v 1.3 2013/05/31 23:14:44 ottxor Exp $
+
+*hub-9999 (07 Dec 2013)
+
+ 07 Dec 2013; Justin Lecher <jlec@gentoo.org> +hub-9999.ebuild, +metadata.xml:
+ Add live ebuild
+
+*hub-1.10.6 (31 May 2013)
+
+ 31 May 2013; Christoph Junghans <ottxor@gentoo.org> +hub-1.10.6.ebuild,
+ -hub-1.10.4.ebuild:
+ version bump (bug #471786, thx to Ewoud)
+
+ 11 Jan 2013; Christoph Junghans <ottxor@gentoo.org> hub-1.10.4.ebuild:
+ updated SRC_URI
+
+*hub-1.10.4 (10 Jan 2013)
+
+ 10 Jan 2013; Christoph Junghans <ottxor@gentoo.org> +hub-1.10.4.ebuild,
+ +metadata.xml:
+ initial commit
diff --git a/dev-vcs/hub/hub-9999.ebuild b/dev-vcs/hub/hub-9999.ebuild
new file mode 100644
index 0000000..ed012b5
--- /dev/null
+++ b/dev-vcs/hub/hub-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hub/hub-1.10.6.ebuild,v 1.1 2013/05/31 23:14:44 ottxor Exp $
+
+EAPI="5"
+
+USE_RUBY="ruby18 ruby19"
+RUBY_FAKEGEM_TASK_DOC=
+RUBY_FAKEGEM_EXTRADOC="HISTORY.md README.md"
+
+inherit git-r3 readme.gentoo ruby-fakegem
+
+ruby_add_bdepend "test? ( dev-ruby/webmock dev-util/cucumber )"
+
+DESCRIPTION="command-line wrapper for git that makes you better at GitHub"
+HOMEPAGE="http://defunkt.io/hub/"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/github/hub.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+RDEPEND=">=dev-vcs/git-1.7.3"
+
+DOC_CONTENTS="You may want to add 'alias git=hub' to your .{csh,bash}rc"
+
+src_unpack() {
+ local EGIT_CHECKOUT_DIR="${WORKDIR}/all/${P}"
+
+ ruby-ng_src_unpack
+ git-r3_src_unpack
+}
+
+src_install() {
+ ruby-ng_src_install
+ readme.gentoo_create_doc
+}
diff --git a/dev-vcs/hub/metadata.xml b/dev-vcs/hub/metadata.xml
new file mode 100644
index 0000000..28f0eb2
--- /dev/null
+++ b/dev-vcs/hub/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ottxor@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">defunkt/hub</remote-id>
+ </upstream>
+</pkgmetadata>