summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-23 09:58:57 +0200
committerJustin Lecher <jlec@gentoo.org>2011-04-23 09:58:57 +0200
commit6fb3a1e918f9061f47255877e4cf1653666d0f54 (patch)
tree7fae6e712fb1ca874effe58835528694efabded7 /app-backup
parentVersion Bump (diff)
downloadbetagarden-6fb3a1e918f9061f47255877e4cf1653666d0f54.tar.gz
betagarden-6fb3a1e918f9061f47255877e4cf1653666d0f54.tar.bz2
betagarden-6fb3a1e918f9061f47255877e4cf1653666d0f54.zip
New addition
(Portage version: 2.2.0_alpha30/git/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/time-drive/ChangeLog10
-rw-r--r--app-backup/time-drive/Manifest14
-rw-r--r--app-backup/time-drive/metadata.xml6
-rw-r--r--app-backup/time-drive/time-drive-0.4.0.ebuild29
4 files changed, 59 insertions, 0 deletions
diff --git a/app-backup/time-drive/ChangeLog b/app-backup/time-drive/ChangeLog
new file mode 100644
index 0000000..6ad2a46
--- /dev/null
+++ b/app-backup/time-drive/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-backup/time-drive
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*time-drive-0.4.0 (23 Apr 2011)
+
+ 23 Apr 2011; Justin Lecher <jlec@gentoo.org> +time-drive-0.4.0.ebuild,
+ +metadata.xml:
+ New addition
+
diff --git a/app-backup/time-drive/Manifest b/app-backup/time-drive/Manifest
new file mode 100644
index 0000000..7c5b15d
--- /dev/null
+++ b/app-backup/time-drive/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST Time-Drive-0.4.0.zip 3913034 RMD160 188c36ef34357c4c6a4c028abca38cf8308b8198 SHA1 35aa2ed1b75eec9c3c79468d059f3070e8b87da3 SHA256 e57b59d6de01bb028e30501297f2362b18e1ff9d53a149827f354a96f90b6cf2
+EBUILD time-drive-0.4.0.ebuild 630 RMD160 f008d1cb3e3aa235a7d4b284aa558ddfe5891cdb SHA1 868e5c36f0e633a650741fca7f811977ec8b2df5 SHA256 85188c9ac3cb8a5ba534a28a1eea7b1c3b5a971edc4456c7142c4955cdd395cd
+MISC ChangeLog 261 RMD160 2c5036aecc89d8536a397e30d6d593a25b819477 SHA1 576ea7c02304fff9bccb670958be4432b8a234b5 SHA256 41f6f60ac88802a2f2c318f82164ec8e8a64ab67811dc38d2c55c534dd2f0a19
+MISC metadata.xml 229 RMD160 f0f6417bec31ce8baba6d476664f7210c8c84c98 SHA1 e5f94f5caadc6f843fc90bb7959570cd503676fd SHA256 3b08fca3c878bdfc4e7639f477dd542d55a4ab5dce39a475e82633071d13eb3f
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iEYEARECAAYFAk2yhsEACgkQgAnW8HDreRboUwCfSIlGy8Bq7xaIw7rRthwtixUI
+pzAAoLF1fjxsgW9iR6K80oRxqU87uIEJ
+=V81x
+-----END PGP SIGNATURE-----
diff --git a/app-backup/time-drive/metadata.xml b/app-backup/time-drive/metadata.xml
new file mode 100644
index 0000000..e6233b5
--- /dev/null
+++ b/app-backup/time-drive/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/app-backup/time-drive/time-drive-0.4.0.ebuild b/app-backup/time-drive/time-drive-0.4.0.ebuild
new file mode 100644
index 0000000..a3d8077
--- /dev/null
+++ b/app-backup/time-drive/time-drive-0.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils versionator
+
+MY_PV="$(get_version_component_range 1-2)"
+
+DESCRIPTION="Linux Backup, Done Right"
+HOMEPAGE="https://launchpad.net/time-drive"
+SRC_URI="http://launchpad.net/${PN}/${MY_PV}/${MY_PV}/+download/Time-Drive-${PV}.zip"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+IUSE=""
+
+RDEPEND="
+ app-backup/duplicity
+ dev-python/PyQt4"
+DEPEND="app-arch/unzip"
+
+PYTHON_MODNAME="timedrive"