summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sebastian@pipping.org>2013-06-18 23:02:21 +0200
committerSebastian Pipping <sebastian@pipping.org>2013-06-18 23:16:58 +0200
commitdba437c255db2f588a2c3e8098179f3d4593b3c9 (patch)
treeb75ecf85a8e1bb357d0c77da1ebbd7219853c205
parentwww-servers/pathod: Remove, newer versions in gentoo-x86 (diff)
downloadbetagarden-dba437c255db2f588a2c3e8098179f3d4593b3c9.tar.gz
betagarden-dba437c255db2f588a2c3e8098179f3d4593b3c9.tar.bz2
betagarden-dba437c255db2f588a2c3e8098179f3d4593b3c9.zip
x11-misc/slinp: 13.02
-rw-r--r--licenses/PIZZA-WARE-427
-rw-r--r--x11-misc/slinp/Manifest1
-rw-r--r--x11-misc/slinp/files/slinp-13.02-ldflags.patch37
-rw-r--r--x11-misc/slinp/metadata.xml8
-rw-r--r--x11-misc/slinp/slinp-13.02.ebuild31
5 files changed, 84 insertions, 0 deletions
diff --git a/licenses/PIZZA-WARE-42 b/licenses/PIZZA-WARE-42
new file mode 100644
index 0000000..292bf97
--- /dev/null
+++ b/licenses/PIZZA-WARE-42
@@ -0,0 +1,7 @@
+------------------------------------------------------------------
+"THE PIZZA-WARE LICENSE" (Revision 42):
+Peter Hofmann <pcode@uninformativ.de> wrote these files. As long as you
+retain this notice you can do whatever you want with this stuff. If we
+meet some day, and you think this stuff is worth it, you can buy me a
+pizza in return.
+------------------------------------------------------------------
diff --git a/x11-misc/slinp/Manifest b/x11-misc/slinp/Manifest
new file mode 100644
index 0000000..0533a7b
--- /dev/null
+++ b/x11-misc/slinp/Manifest
@@ -0,0 +1 @@
+DIST slinp-13.02.tar.gz 16043 SHA256 5e515888b06ae7b0f5700b6772a3ff58241c3fcc1b931b226de8a93d5f8094c7 SHA512 1fb132678cc68a97fbda70deb2faff5002296d771b1c4156707376e382dbc843be1e158b890d7e0dd2d6204a974e2b8c862d062ac9938c10ce25cc6e4e4ae8eb WHIRLPOOL 12ef8806e8e0a953ac3c29c4e56bde6ef842aeeae7b37466c2511fbbdd21ff2827c1de498ac7a515dc93c86f54e25fa8acf4531954ca4387498cc5cddee0fb77
diff --git a/x11-misc/slinp/files/slinp-13.02-ldflags.patch b/x11-misc/slinp/files/slinp-13.02-ldflags.patch
new file mode 100644
index 0000000..9afa4ae
--- /dev/null
+++ b/x11-misc/slinp/files/slinp-13.02-ldflags.patch
@@ -0,0 +1,37 @@
+From 766e5138df4639983e80b7a15904d67fb81196e6 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Tue, 18 Jun 2013 22:54:08 +0200
+Subject: [PATCH] Respect LDFLAGS
+
+---
+ Makefile | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 0452647..631929e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,5 @@
+ # Variables for DESTDIR and friends.
++CFLAGS += -Wall -Wextra
+
+ INSTALL = install
+ INSTALL_PROGRAM = $(INSTALL)
+@@ -22,12 +23,12 @@ all: prescontrol/prescontrol showpdf/showpdf slidenotes/slidenotes \
+ stopclock/stopclock
+
+ showpdf/showpdf: showpdf/showpdf.c showpdf/showpdf.h
+- $(CC) -Wall -Wextra $(CFLAGS) \
++ $(CC) $(CFLAGS) $(LDFLAGS) \
+ -o $@ $< \
+ `pkg-config --cflags --libs gtk+-3.0 poppler-glib`
+
+ stopclock/stopclock: stopclock/stopclock.c stopclock/stopclock.h
+- $(CC) -Wall -Wextra $(CFLAGS) \
++ $(CC) $(CFLAGS) $(LDFLAGS) \
+ -o $@ $< \
+ `pkg-config --cflags --libs gtk+-3.0`
+
+--
+1.8.2.1
+
diff --git a/x11-misc/slinp/metadata.xml b/x11-misc/slinp/metadata.xml
new file mode 100644
index 0000000..16bcc9f
--- /dev/null
+++ b/x11-misc/slinp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-misc/slinp/slinp-13.02.ebuild b/x11-misc/slinp/slinp-13.02.ebuild
new file mode 100644
index 0000000..a792527
--- /dev/null
+++ b/x11-misc/slinp/slinp-13.02.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+PYTHON_COMPAT=( python{3_1,3_2,3_3} )
+inherit eutils python-any-r1
+
+DESCRIPTION="PDF presentation tool chest, successor to x11-misc/pdfpres"
+HOMEPAGE="http://www.uninformativ.de/projects/?q=slinp"
+SRC_URI="https://github.com/vain/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="PIZZA-WARE-42"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-text/poppler
+ x11-libs/gtk+:3"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix=/usr install
+ dodoc README.md
+}