summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2012-05-18 17:36:48 +0900
committerBenda Xu <heroxbd@gentoo.org>2012-05-18 17:36:48 +0900
commitfb26a5c2df5e1fde31491ebeff69112712008353 (patch)
tree2f8414516404877c9df8e29df0c2b2536ab2bd5c /net-mail
downloadandroid-fb26a5c2df5e1fde31491ebeff69112712008353.tar.gz
android-fb26a5c2df5e1fde31491ebeff69112712008353.tar.bz2
android-fb26a5c2df5e1fde31491ebeff69112712008353.zip
initial commit
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/lurker/Manifest3
-rw-r--r--net-mail/lurker/lurker-2.3.ebuild70
2 files changed, 73 insertions, 0 deletions
diff --git a/net-mail/lurker/Manifest b/net-mail/lurker/Manifest
new file mode 100644
index 0000000..c841fe1
--- /dev/null
+++ b/net-mail/lurker/Manifest
@@ -0,0 +1,3 @@
+DIST lurker-2.3.tar.gz 320420 RMD160 c4514fb90d21b0d470ca928b58a708f24abe2155 SHA1 11976e94f3846e09b7164d359605f5a5081b7d70 SHA256 d174d16d62c32ee5899cb346544b35ccde1b70e8a81aa971e52ec8818365d038
+DIST mimelib-3.1.1.tar.gz 194838 RMD160 7f7f246245cdc70264a0b3f4997ff8d1ca51a84c SHA1 6890d5aaeb51543c2b4104d624dfdfbb8a7e77a1 SHA256 831f553639944d23ef7fc6d27a98c88b7a1afa4626b8feef98e8932403ec6e6c
+EBUILD lurker-2.3.ebuild 1890 RMD160 5c94b515f339e11cc3ad186d4fef8ce1db688b31 SHA1 f75c4c9487efc8acb0c9d335d9ebf252b14912e6 SHA256 a6bc0e2862b57c01309fab52bc0c389f6dbe6838be82ddff8549b60173dc9c5c
diff --git a/net-mail/lurker/lurker-2.3.ebuild b/net-mail/lurker/lurker-2.3.ebuild
new file mode 100644
index 0000000..ce9df92
--- /dev/null
+++ b/net-mail/lurker/lurker-2.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit eutils autotools flag-o-matic webapp
+
+DESCRIPTION="Lurker is a mailing list archiver designed for capacity, speed, simplicity, and configurability."
+HOMEPAGE="http://lurker.sourceforge.net/"
+MIMELIB_URI="mirror://sourceforge/lurker/mimelib-3.1.1.tar.gz"
+SRC_URI="mirror://sourceforge/lurker/${P}.tar.gz ${MIMELIB_URI}"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+
+DEPEND="sys-libs/zlib
+ dev-libs/libxslt"
+
+need_httpd_cgi
+
+S=${WORKDIR}/${P}
+MIMELIB=${WORKDIR}/mimelib
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_configure() {
+ echo "jopa!"
+ cd ${S}
+ ln -s ${MIMELIB} mimelib
+ echo ${S}
+ econf --with-mimelib-local \
+ --with-default-www-dir=${MY_HTDOCSDIR} \
+ --with-cgi-bin-dir=${MY_CGIBINDIR} \
+ || die "econf failed"
+}
+
+src_compile() {
+ cd ${S}
+ emake || die "make failed"
+}
+
+src_install() {
+ webapp_src_preinst
+ emake install DESTDIR=${D} || die "install failed"
+ emake install-config DESTDIR=${D} || die "install-config failed"
+ dodoc ChangeLog FAQ INSTALL README AUTHORS COPYING
+ # mv ${ED}/etc/lurker/lurker.conf ${D}${MY_HOSTROOTDIR} || die
+ # webapp_configfile ${D}${MY_HOSTROOTDIR}/lurker.conf
+ # webapp_postinst_txt en INSTALL
+ # webapp_src_install
+}
+
+pkg_postinst() {
+ ewarn "The lurker.conf file will be installed into your "
+ ewarn "document root directory for the virtual host."
+ ewarn "use the command:"
+ ewarn "webapp-config -I -d / -h lurker.example.org lurker 2.3"
+ ewarn "to install lurker for each virtual host and then edit"
+ ewarn "the lurker.conf file for that host."
+ ewarn
+ ewarn "You should also have access control in place over the"
+ ewarn "lurker website. There is a sample apache configuration"
+ ewarn "file in /etc/lurker/apache.conf that you could include"
+ ewarn "in your apache configuration."
+}