aboutsummaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
authorAndré Erdmann <dywi@mailerd.de>2014-02-16 17:20:29 +0100
committerAndré Erdmann <dywi@mailerd.de>2014-02-16 17:27:44 +0100
commit872a20162214df913b8b666bd9c3131cde5f28d0 (patch)
tree0a1eadd52c44adbb0826b41b4e14d6e855f9a544 /bin
parentroverlay-9999.ebuild: rovelay is no longer compatible with python2.7 (diff)
downloadR_overlay-872a20162214df913b8b666bd9c3131cde5f28d0.tar.gz
R_overlay-872a20162214df913b8b666bd9c3131cde5f28d0.tar.bz2
R_overlay-872a20162214df913b8b666bd9c3131cde5f28d0.zip
bin/roverlay, bin/invoke_pyscript: fix $PYTHON
Don't execute scripts directly if $PYTHON is set.
Diffstat (limited to 'bin')
-rwxr-xr-xbin/invoke_pyscript.bash2
-rwxr-xr-xbin/roverlay2
2 files changed, 2 insertions, 2 deletions
diff --git a/bin/invoke_pyscript.bash b/bin/invoke_pyscript.bash
index c8ed2c8..41af30d 100755
--- a/bin/invoke_pyscript.bash
+++ b/bin/invoke_pyscript.bash
@@ -12,7 +12,7 @@ export PYTHONPATH="${PRJROOT}${PYTHONPATH:+:}${PYTHONPATH}"
cd "${PRJROOT}" || exit
-if [[ -x "${PYSCRIPT}" ]]; then
+if [[ -z "${PYTHON-}" ]] && [[ -x "${PYSCRIPT}" ]]; then
exec ${PYSCRIPT} "$@"
elif [[ -f "${PYSCRIPT}" ]]; then
exec ${PYTHON:-python} ${PYSCRIPT} "$@"
diff --git a/bin/roverlay b/bin/roverlay
index c6acce5..3c385b8 100755
--- a/bin/roverlay
+++ b/bin/roverlay
@@ -14,7 +14,7 @@ export PYTHONPATH="${PRJROOT}${PYTHONPATH:+:}${PYTHONPATH}"
cd "${PRJROOT}" || exit
-if [[ -x "${PYSCRIPT}" ]]; then
+if [[ -z "${PYTHON-}" ]] && [[ -x "${PYSCRIPT}" ]]; then
exec ${PYSCRIPT} "$@"
elif [[ -f "${PYSCRIPT}" ]]; then
exec ${PYTHON:-python} ${PYSCRIPT} "$@"