aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-10-03 10:41:51 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-10-04 12:09:29 +0200
commit349cc4a507c4d84fcadf61f42159ea6412717896 (patch)
tree8d6e64af681fb4e1e41a1fc01b4f225f56aa147d /src/shared/firewall-util.h
parentmeson: check for sys/auxv.h (diff)
downloadsystemd-349cc4a507c4d84fcadf61f42159ea6412717896.tar.gz
systemd-349cc4a507c4d84fcadf61f42159ea6412717896.tar.bz2
systemd-349cc4a507c4d84fcadf61f42159ea6412717896.zip
build-sys: use #if Y instead of #ifdef Y everywhere
The advantage is that is the name is mispellt, cpp will warn us. $ git grep -Ee "conf.set\('(HAVE|ENABLE)_" -l|xargs sed -r -i "s/conf.set\('(HAVE|ENABLE)_/conf.set10('\1_/" $ git grep -Ee '#ifn?def (HAVE|ENABLE)' -l|xargs sed -r -i 's/#ifdef (HAVE|ENABLE)/#if \1/; s/#ifndef (HAVE|ENABLE)/#if ! \1/;' $ git grep -Ee 'if.*defined\(HAVE' -l|xargs sed -i -r 's/defined\((HAVE_[A-Z0-9_]*)\)/\1/g' $ git grep -Ee 'if.*defined\(ENABLE' -l|xargs sed -i -r 's/defined\((ENABLE_[A-Z0-9_]*)\)/\1/g' + manual changes to meson.build squash! build-sys: use #if Y instead of #ifdef Y everywhere v2: - fix incorrect setting of HAVE_LIBIDN2
Diffstat (limited to 'src/shared/firewall-util.h')
-rw-r--r--src/shared/firewall-util.h2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/shared/firewall-util.h b/src/shared/firewall-util.h
index c39b34cf8..5915266b4 100644
--- a/src/shared/firewall-util.h
+++ b/src/shared/firewall-util.h
@@ -24,7 +24,7 @@
#include "in-addr-util.h"
-#ifdef HAVE_LIBIPTC
+#if HAVE_LIBIPTC
int fw_add_masquerade(
bool add,