diff options
author | Lennart Poettering <lennart@poettering.net> | 2010-02-02 22:22:51 +0100 |
---|---|---|
committer | Lennart Poettering <lennart@poettering.net> | 2010-02-02 22:22:51 +0100 |
commit | 5630af71d72a2fa8142886ca2fb37e69a1906bca (patch) | |
tree | 8ea7cc0a6bca89ffbc5ce5f76aa79eed54f0c271 /Makefile | |
parent | build: make gcc shut up (diff) | |
download | systemd-5630af71d72a2fa8142886ca2fb37e69a1906bca.tar.gz systemd-5630af71d72a2fa8142886ca2fb37e69a1906bca.tar.bz2 systemd-5630af71d72a2fa8142886ca2fb37e69a1906bca.zip |
client: add a very basic Vala command line tool
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 7 |
1 files changed, 5 insertions, 2 deletions
@@ -29,7 +29,7 @@ COMMON= \ dbus-unit.o \ dbus-job.o -all: systemd test-engine test-job-type systemd-logger +all: systemd test-engine test-job-type systemd-logger systemctl systemd: main.o $(COMMON) $(CC) $(CFLAGS) -o $@ $^ $(LIBS) @@ -43,5 +43,8 @@ test-engine: test-engine.o $(COMMON) test-job-type: test-job-type.o $(COMMON) $(CC) $(CFLAGS) -o $@ $^ $(LIBS) +systemctl: systemctl.vala + valac --save-temps systemctl.vala --pkg=dbus-glib-1 --pkg=posix + clean: - rm -f *.o systemd test-engine + rm -f *.o systemd test-engine systemctl |