aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmin Rigo <arigo@tunes.org>2013-11-01 18:41:29 +0100
committerArmin Rigo <arigo@tunes.org>2013-11-01 18:41:29 +0100
commit7d2bd0a94f210d94779735847408c31f0720058e (patch)
tree273f949cab56a68710d3fec6663388b77d1d7602 /Makefile
parentMention the MAKEFLAGS=-j.. option (diff)
downloadpypy-7d2bd0a94f210d94779735847408c31f0720058e.tar.gz
pypy-7d2bd0a94f210d94779735847408c31f0720058e.tar.bz2
pypy-7d2bd0a94f210d94779735847408c31f0720058e.zip
Improve the documentation of -jN
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index e800202051..449de3dcb9 100644
--- a/Makefile
+++ b/Makefile
@@ -12,7 +12,7 @@ endif
pypy-c:
@echo
- @echo "============================================================="
+ @echo "===================================================================="
ifeq ($(PYPY_EXECUTABLE),)
@echo "Building a regular (jitting) version of PyPy, using CPython."
@echo "This takes around 2 hours and $(URAM) GB of RAM."
@@ -23,8 +23,10 @@ else
@echo "$(PYPY_EXECUTABLE) to run the translation itself."
@echo "This takes around 45 minutes and $(URAM) GB of RAM."
endif
- @echo "If you have N cores, consider setting \`\`MAKEFLAGS=-jN''."
- @echo "============================================================="
+ @echo
+ @echo "If you have N cores, consider running \`\`MAKEFLAGS=-jN make'' to"
+ @echo "speed up the last part of translation (\`\`make -jN'' does not work!)"
+ @echo "===================================================================="
@echo
@sleep 5
$(RUNINTERP) rpython/bin/rpython -Ojit pypy/goal/targetpypystandalone.py