diff options
author | Ilya Leoshkevich <iii@linux.ibm.com> | 2018-08-10 09:07:44 +0200 |
---|---|---|
committer | Stefan Liebler <stli@linux.ibm.com> | 2018-08-10 09:07:44 +0200 |
commit | 8d997d2253e742546db2b27c8ee56edbbe4c906c (patch) | |
tree | a22444850dd6a7101fcf200049e0a73090c0b1f9 | |
parent | S390: Test that lazy binding does not clobber R0 (diff) | |
download | glibc-8d997d2253e742546db2b27c8ee56edbbe4c906c.tar.gz glibc-8d997d2253e742546db2b27c8ee56edbbe4c906c.tar.bz2 glibc-8d997d2253e742546db2b27c8ee56edbbe4c906c.zip |
Move __fentry__ version definition to sysdeps/{i386,x86_64}
__fentry__ symbol is currently not defined for other architectures.
Attempts to introduce it cause abicheck to fail, because it will be
available since 2.29 earliest, and not 2.13, which is the case for
Intel. With the new code, abicheck passes for i686-linux-gnu,
x86_64-linux-gnu and x86_64-linux-gnu32 triples.
ChangeLog:
* stdlib/Versions: Remove __fentry__.
* sysdeps/i386/Versions: Add __fentry__.
* sysdeps/x86_64/Versions: Add __fentry__.
-rw-r--r-- | ChangeLog | 6 | ||||
-rw-r--r-- | stdlib/Versions | 3 | ||||
-rw-r--r-- | sysdeps/i386/Versions | 3 | ||||
-rw-r--r-- | sysdeps/x86_64/Versions | 3 |
4 files changed, 12 insertions, 3 deletions
@@ -1,5 +1,11 @@ 2018-08-10 Ilya Leoshkevich <iii@linux.ibm.com> + * stdlib/Versions: Remove __fentry__. + * sysdeps/i386/Versions: Add __fentry__. + * sysdeps/x86_64/Versions: Add __fentry__. + +2018-08-10 Ilya Leoshkevich <iii@linux.ibm.com> + * sysdeps/s390/Makefile: Register the new tests. * sysdeps/s390/tst-dl-runtime-mod.S: New file. * sysdeps/s390/tst-dl-runtime-profile-audit.c: New file. diff --git a/stdlib/Versions b/stdlib/Versions index a2dfa322ed..9e665d4c26 100644 --- a/stdlib/Versions +++ b/stdlib/Versions @@ -105,9 +105,6 @@ libc { GLIBC_2.10 { quick_exit; __cxa_at_quick_exit; } - GLIBC_2.13 { - __fentry__; - } GLIBC_2.17 { secure_getenv; } diff --git a/sysdeps/i386/Versions b/sysdeps/i386/Versions index 7be44aad7a..36e23b466a 100644 --- a/sysdeps/i386/Versions +++ b/sysdeps/i386/Versions @@ -25,6 +25,9 @@ libc { __strpbrk_cg; __strpbrk_g; __strrchr_c; __strrchr_g; __strspn_c1; __strspn_cg; __strspn_g; __strstr_cg; __strstr_g; } + GLIBC_2.13 { + __fentry__; + } } libm { GLIBC_2.1 { diff --git a/sysdeps/x86_64/Versions b/sysdeps/x86_64/Versions index a437f85e6e..e94758b236 100644 --- a/sysdeps/x86_64/Versions +++ b/sysdeps/x86_64/Versions @@ -2,6 +2,9 @@ libc { GLIBC_2.14 { memcpy; } + GLIBC_2.13 { + __fentry__; + } } libm { GLIBC_2.1 { |