summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/bbacpi/files')
-rw-r--r--x11-misc/bbacpi/files/bbacpi-0.1.5-asneeded.patch40
-rw-r--r--x11-misc/bbacpi/files/bbacpi-0.1.5-noextraquals.diff14
-rw-r--r--x11-misc/bbacpi/files/bbacpi-0.1.5-overflows.patch79
3 files changed, 0 insertions, 133 deletions
diff --git a/x11-misc/bbacpi/files/bbacpi-0.1.5-asneeded.patch b/x11-misc/bbacpi/files/bbacpi-0.1.5-asneeded.patch
deleted file mode 100644
index 5b8160a..0000000
--- a/x11-misc/bbacpi/files/bbacpi-0.1.5-asneeded.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Fix configure check that appended -lX11 to $LDFLAGS instead of allowing the
-default handling that appended it to $LIBS.
-
-https://bugs.gentoo.org/show_bug.cgi?id=338936
-
-Patch written by Kevin Pyle
---- configure.in
-+++ configure.in
-@@ -89,13 +89,10 @@
-
- CFLAGS="$CFLAGS $X_CFLAGS"
- CXXFLAGS="$CXXFLAGS $X_CFLAGS"
--LDFLAGS="$LDFLAGS $X_LIBS $X_PRE_LIBS"
- dnl Checks for X libraries.
--AC_CHECK_LIB(X11, XOpenDisplay, LDFLAGS="$LDFLAGS -lX11",
-+AC_CHECK_LIB(X11, XOpenDisplay,,
- AC_MSG_ERROR(XOpenDisplay not found in -lX11))
-
--LDFLAGS="$LDFLAGS $X_EXTRA_LIBS"
--
- dnl Check for Imlib
- AC_MSG_CHECKING([for Imlib])
- AC_ARG_WITH(imlib,[ --with-imlib[=path] Use Imlib for images [path to imlib-config]],
---- Makefile.am
-+++ Makefile.am
-@@ -1,4 +1,4 @@
--AM_CPPFLAGS = @CPPFLAGS@ @INTERLACE@ \
-+AM_CPPFLAGS = @INTERLACE@ \
- -DGLOBAL_BB=\"$(datadir)/bbtools/bbacpi.bb\" \
- -DGLOBAL_NOBB=\"$(datadir)/bbtools/bbacpi.nobb\" \
- -DGLOBAL_DATA=\"$(datadir)/bbtools\"
-@@ -18,7 +18,7 @@
- Basemenu.cc Basemenu.hh \
- blackboxstyle.hh
- EXTRA_DIST = BUGS TODO
--bbacpi_LDADD = @X_LIBS@
-+bbacpi_LDADD = @X_PRE_LIBS@ @X_LIBS@
-
- if USE_IMLIB
- AM_CPPFLAGS += @IMAGE_CFLAGS@ -D__IMLIB
diff --git a/x11-misc/bbacpi/files/bbacpi-0.1.5-noextraquals.diff b/x11-misc/bbacpi/files/bbacpi-0.1.5-noextraquals.diff
deleted file mode 100644
index abf409b..0000000
--- a/x11-misc/bbacpi/files/bbacpi-0.1.5-noextraquals.diff
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -urN bbacpi-0.1.5/work/bbacpi-0.1.5/resource.hh bbacpi-0.1.5-r1/work/bbacpi-0.1.5/resource.hh
---- bbacpi-0.1.5/work/bbacpi-0.1.5/resource.hh 2004-05-15 08:10:52.000000000 -0400
-+++ bbacpi-0.1.5-r1/work/bbacpi-0.1.5/resource.hh 2006-07-19 09:29:28.000000000 -0400
-@@ -126,8 +126,8 @@
- {
-
- public:
-- Resource::Resource(ToolWindow *);
-- Resource::~Resource(void);
-+ Resource(ToolWindow *);
-+ ~Resource(void);
-
- struct FRAME frame;
- struct LABEL label;
diff --git a/x11-misc/bbacpi/files/bbacpi-0.1.5-overflows.patch b/x11-misc/bbacpi/files/bbacpi-0.1.5-overflows.patch
deleted file mode 100644
index 23a0ce6..0000000
--- a/x11-misc/bbacpi/files/bbacpi-0.1.5-overflows.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-Fix buffer overflows
-
-https://bugs.gentoo.org/show_bug.cgi?id=338936
-
-Patch written by Kevin Pyle
---- bbacpi.cc
-+++ bbacpi.cc
-@@ -167,7 +167,7 @@
- if (ret = (fp = fopen(name, "r"))) {
- char buffer[100];
- char present[20];
-- fgets(buffer,128,fp);
-+ fgets(buffer, sizeof(buffer),fp);
- sscanf(buffer,"present: %s", present);
- if (strncmp(present, "yes", 3) != 0) {
- fprintf(stderr, "Device %s not present.\n", device);
-@@ -195,7 +195,7 @@
- {
- /* Read data in any order */
- found = 0;
-- while (found < 11 && (fgets(buffer, 63, fp) != NULL)) {
-+ while (found < 11 && (fgets(buffer, sizeof(buffer), fp) != NULL)) {
- /* Present */
- if (strncmp(buffer, "present:", 7) == 0
- || strncmp(buffer, "Present:", 7) == 0) {
-@@ -277,7 +277,7 @@
- {
- /* Read data in any order */
- found = 0;
-- while (found < 11 && (fgets(buffer, 63, fp) != NULL)) {
-+ while (found < 11 && (fgets(buffer, sizeof(buffer), fp) != NULL)) {
- /* Present */
- if (strncmp(buffer, "present:", 7) == 0
- || strncmp(buffer, "Present:", 7) == 0) {
-@@ -361,7 +361,7 @@
- if ((fp = fopen(names.temptrip, "r")))
- {
- found = 0;
-- while (found < 2 && (fgets(buffer,128,fp) != NULL)) {
-+ while (found < 2 && (fgets(buffer, sizeof(buffer),fp) != NULL)) {
- /* Critical */
- if (strncmp(buffer, "critical", 8) == 0
- || strncmp(buffer, "Critical", 8) == 0) {
-@@ -425,7 +425,7 @@
- if (file_status.st_mtime != last_mtime)
- {
- found = 0;
-- while (found < 4 && (fgets(buffer, 63, fp) != NULL)) {
-+ while (found < 4 && (fgets(buffer, sizeof(buffer), fp) != NULL)) {
- /* Charging state */
- if (strncmp(buffer, "charging state:", 15) == 0
- || strncmp(buffer, "Charging State:", 15) == 0) {
-@@ -463,7 +463,7 @@
- if (file_status.st_mtime != last_mtime)
- {
- found = 0;
-- while (found < 4 && (fgets(buffer, 63, fp) != NULL)) {
-+ while (found < 4 && (fgets(buffer, sizeof(buffer), fp) != NULL)) {
- /* Charging state */
- if (strncmp(buffer, "charging state:", 15) == 0
- || strncmp(buffer, "Charging State:", 15) == 0) {
-@@ -497,7 +497,7 @@
- if ((fp = fopen(names.adapter, "r")))
- {
- found = 0;
-- while (found < 1 && (fgets(buffer, 63,fp) != NULL)) {
-+ while (found < 1 && (fgets(buffer, sizeof(buffer),fp) != NULL)) {
- if (strncmp(buffer, "state:", 6) == 0
- || strncmp(buffer, "State:", 6) == 0) {
- sscanf(buffer+offset,"%s", adapter.state);
-@@ -511,7 +511,7 @@
- if ((fp = fopen(names.temperature, "r")))
- {
- found = 0;
-- while (found < 1 && (fgets(buffer, 63,fp) != NULL)) {
-+ while (found < 1 && (fgets(buffer, sizeof(buffer),fp) != NULL)) {
- if (strncmp(buffer, "temperature:", 12) == 0
- || strncmp(buffer, "Temperature:", 12) == 0) {
- sscanf(buffer+offset,"%u", &temperature.celcius);