summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/pidgin-awayonlock/pidgin-awayonlock-0.5.2.ebuild')
-rw-r--r--x11-plugins/pidgin-awayonlock/pidgin-awayonlock-0.5.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-awayonlock/pidgin-awayonlock-0.5.2.ebuild b/x11-plugins/pidgin-awayonlock/pidgin-awayonlock-0.5.2.ebuild
new file mode 100644
index 0000000..93c19ae
--- /dev/null
+++ b/x11-plugins/pidgin-awayonlock/pidgin-awayonlock-0.5.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+MY_PN="${PN/pidgin-}"
+MY_P="${MY_PN}-${PV}"
+
+inherit cmake-utils
+
+DESCRIPTION="Away-on-Lock change your Pidgin status when the screensaver gets activated"
+HOMEPAGE="http://costela.net/projects/awayonlock/"
+SRC_URI="http://costela.net/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-im/pidgin
+ dev-libs/dbus-glib"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ cmake-utils_src_install
+ dodoc AUTHORS
+ insinto /usr/share/doc/${PF}
+ doins utils/mimic_gnome-screensaver.py
+}