summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-04-22 09:40:36 +0000
committerChristian Heim <phreak@gentoo.org>2007-04-22 09:40:36 +0000
commitc26be79df12ffd870faaf058979a86362a9ef999 (patch)
tree7438cef79f091cf0fe60cea4885ea3bd8fff2106
parentRemoving the lame elog, using strip-flags instead. Also marking the QA_TEXTRELS. (diff)
downloadphreak-c26be79df12ffd870faaf058979a86362a9ef999.tar.gz
phreak-c26be79df12ffd870faaf058979a86362a9ef999.tar.bz2
phreak-c26be79df12ffd870faaf058979a86362a9ef999.zip
Quote the occurences of ${D}, rewrite the pax-mark and its explanation.
svn path=/; revision=319
-rw-r--r--hardened/dev-lang/ocaml/Manifest8
-rw-r--r--hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild15
2 files changed, 13 insertions, 10 deletions
diff --git a/hardened/dev-lang/ocaml/Manifest b/hardened/dev-lang/ocaml/Manifest
index 594f4e6..2856dab 100644
--- a/hardened/dev-lang/ocaml/Manifest
+++ b/hardened/dev-lang/ocaml/Manifest
@@ -19,10 +19,10 @@ MD5 bcc5109143faee7e7b8f7f76bd4726a7 files/ocaml-rebuild.sh 1361
RMD160 a9c452fbea18de3b38d8240f887f8595e529643e files/ocaml-rebuild.sh 1361
SHA256 a8004cd4bca96ab3fc595fcfd7dbe88903833f9e430149c3d04c9fda84362b64 files/ocaml-rebuild.sh 1361
DIST ocaml-3.09.3.tar.bz2 2038617 RMD160 fdc124218c556c62c897ee6720970279e2d5426b SHA1 5d63c6e0d13463f85c0d5147d641d2bceef87d6b SHA256 607842b4f4917a759f19541a421370a834f5b948855ca54cef40d22b19a0934f
-EBUILD ocaml-3.09.3-r1.ebuild 3711 RMD160 6a503ede074555cfdc5db04d879f36f635d4bedc SHA1 b9d2e5207b80166b8eefa2ebdd022d359bf14998 SHA256 0644e4eda31018d1ffe8ccf436be871ec7ecd120a801c4a6c4279058a4e4b9fb
-MD5 c47be275f4e1d457cd6e781661a599c5 ocaml-3.09.3-r1.ebuild 3711
-RMD160 6a503ede074555cfdc5db04d879f36f635d4bedc ocaml-3.09.3-r1.ebuild 3711
-SHA256 0644e4eda31018d1ffe8ccf436be871ec7ecd120a801c4a6c4279058a4e4b9fb ocaml-3.09.3-r1.ebuild 3711
+EBUILD ocaml-3.09.3-r1.ebuild 3863 RMD160 c9ff8ee8498171472d86e29b807834065ee37fa4 SHA1 882724f5f5cca626e9c1afa5ccd83ef40297a93f SHA256 ad320e4099dd241249be39875a6d8a16a5bd3cc43439306f34a448e41eff185d
+MD5 cb05ddc48c336819b40eaf405936382e ocaml-3.09.3-r1.ebuild 3863
+RMD160 c9ff8ee8498171472d86e29b807834065ee37fa4 ocaml-3.09.3-r1.ebuild 3863
+SHA256 ad320e4099dd241249be39875a6d8a16a5bd3cc43439306f34a448e41eff185d ocaml-3.09.3-r1.ebuild 3863
MD5 71f3dc5bc2ee57a403689b56bc1a85c1 files/digest-ocaml-3.09.3-r1 244
RMD160 e7f0898889b94faae3b1481555bac42e9298b370 files/digest-ocaml-3.09.3-r1 244
SHA256 19708f759185ed39623e03921462ba20fb6f3533268673d2bcd7dd07cef57350 files/digest-ocaml-3.09.3-r1 244
diff --git a/hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild b/hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild
index f2a2df2..defb049 100644
--- a/hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild
+++ b/hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild
@@ -77,9 +77,9 @@ src_test() {
}
src_install() {
- make BINDIR=${D}/usr/bin \
- LIBDIR=${D}/usr/$(get_libdir)/ocaml \
- MANDIR=${D}/usr/share/man \
+ make BINDIR="${D}"/usr/bin \
+ LIBDIR="${D}"/usr/$(get_libdir)/ocaml \
+ MANDIR="${D}"/usr/share/man \
install || die "make install failed!"
# Install the compiler libs
@@ -96,9 +96,12 @@ src_install() {
dodoc Changes INSTALL LICENSE README Upgrading
- # Pax-mark the ocaml compilers, since they are trying to rewrite the segment
- # (which will obviously fail on systems which are PAX_MPROTECT enabled).
- pax-mark -m "${D}"/usr/bin/*.opt
+ # Turn MPROTECT off for some of the ocaml binaries, since they are trying to
+ # rewrite the segment (which will obviously fail on systems having
+ # PAX_MPROTECT enabled).
+ pax-mark -m "${D}"//usr/bin/ocamldoc.opt "${D}"/usr/bin/ocamldep.opt \
+ "${D}"/usr/bin/ocamllex.opt "${D}"/usr/bin/camlp4r.opt \
+ "${D}"/usr/bin/camlp4o.opt
}
pkg_postinst() {