summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libgsasl/libgsasl-0.2.18.ebuild')
-rw-r--r--net-libs/libgsasl/libgsasl-0.2.18.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-libs/libgsasl/libgsasl-0.2.18.ebuild b/net-libs/libgsasl/libgsasl-0.2.18.ebuild
new file mode 100644
index 0000000..646f8de
--- /dev/null
+++ b/net-libs/libgsasl/libgsasl-0.2.18.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="The GNU SASL library"
+HOMEPAGE="http://www.gnu.org/software/gsasl/"
+SRC_URI="http://josefsson.org/gsasl/releases/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+# TODO: check http://www.gnu.org/software/gsasl/#dependencies for more
+# optional external libraries.
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="kerberos nls idn ntlm"
+PROVIDE="virtual/gsasl"
+DEPEND="virtual/libc
+ nls? ( sys-devel/gettext )
+ kerberos? ( virtual/krb5 )
+ idn? ( net-dns/libidn )
+ ntlm? ( net-libs/libntlm )"
+RDEPEND="${DEPEND}
+ !virtual/gsasl"
+
+src_compile() {
+ econf \
+ $(use_enable kerberos gssapi) \
+ $(use_enable kerberos kerberosv5) \
+ $(use_with idn stringprep) \
+ $(use_enable nls) \
+ $(use_enable ntlm) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "installation failed"
+ dodoc ABOUT-NLS AUTHORS ChangeLog NEWS README README-alpha THANKS || die "dodoc failed"
+}