summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2009-01-07 14:53:50 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2009-01-07 14:53:50 +0000
commitb021fd8f636dafb8e2d4e8cea30aa90921050d23 (patch)
treebb7166c8d1a451b2e71d2fbc845627eaec452309
parentGet proper version in the osgi package (diff)
downloadpauldv-b021fd8f636dafb8e2d4e8cea30aa90921050d23.tar.gz
pauldv-b021fd8f636dafb8e2d4e8cea30aa90921050d23.tar.bz2
pauldv-b021fd8f636dafb8e2d4e8cea30aa90921050d23.zip
Get proper version in the osgi package
svn path=/trunk/overlay/; revision=76
-rw-r--r--dev-java/icu4j/Manifest5
-rw-r--r--dev-java/icu4j/NOTES1
-rw-r--r--dev-java/icu4j/files/icu4j-3.8.1-manifest21
-rw-r--r--dev-java/icu4j/icu4j-3.8.1-r1.ebuild74
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-java/icu4j/Manifest b/dev-java/icu4j/Manifest
new file mode 100644
index 0000000..598f742
--- /dev/null
+++ b/dev-java/icu4j/Manifest
@@ -0,0 +1,5 @@
+AUX icu4j-3.8.1-manifest 789 RMD160 8206b5db3a6268065c036fa49a71e3dee89b81f8 SHA1 f7d69f1ea30ddf02cc30c12d1a397b7ebfddd2e5 SHA256 eaa0018f85175e7e0245aed329bce28ec8c50d7b70b5765d67d65e9b2cd8dd98
+DIST icu4j-3_8_1-docs.jar 1470606 RMD160 8131fc868505050ded8563618f3a287e0a57d8eb SHA1 261ba7e69c97e1ea98f08c878280f9cc313184af SHA256 e3acbb4523ebf90288bde1ff4ebe16241ff8d5a3e53ce9e29636f569a42f0b46
+DIST icu4j-3_8_1-src.jar 13782832 RMD160 8b0feb5d956b4d82ecc69e8da89c572c5c25cc8c SHA1 420d988835f6ac4582ebab90a0f97d2800a8bc4e SHA256 c6b42a4a9fe0d13302897ee0bf2c955b8a7a02af1ee01ad9cdb61a515638ca0f
+EBUILD icu4j-3.8.1-r1.ebuild 2513 RMD160 2e1bbff26a4510645bfce3b51f0922b61716b304 SHA1 3ab0108a27e22cfb77786af7300bd1dbfec35655 SHA256 e09084fe3cdfe3e31f934f60ed5da9fb15967ed95c4e68c37dd2cef7bc64e089
+MISC NOTES 32 RMD160 160cc11fb1875d35767042b63700a685dd9d2257 SHA1 5b6b37251079b4ac46b18078927ce80ca9a6f473 SHA256 446bc6de80f4bd41aafd25966e8d3fadf005f05216440856e043ce4fdbe56643
diff --git a/dev-java/icu4j/NOTES b/dev-java/icu4j/NOTES
new file mode 100644
index 0000000..d34dfc0
--- /dev/null
+++ b/dev-java/icu4j/NOTES
@@ -0,0 +1 @@
+Have proper version for eclipse
diff --git a/dev-java/icu4j/files/icu4j-3.8.1-manifest b/dev-java/icu4j/files/icu4j-3.8.1-manifest
new file mode 100644
index 0000000..35af0ae
--- /dev/null
+++ b/dev-java/icu4j/files/icu4j-3.8.1-manifest
@@ -0,0 +1,21 @@
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: %bundleName
+Bundle-Vendor: %vendorName
+Bundle-SymbolicName: com.ibm.icu; singleton:=true
+Bundle-Version: 3.8.1.v20080530
+Bundle-Localization: plugin
+Export-Package: com.ibm.icu.lang;version="3.8.1",
+ com.ibm.icu.math;version="3.8.1",
+ com.ibm.icu.text;version="3.8.1",
+ com.ibm.icu.util;version="3.8.1",
+ com.ibm.icu.impl;x-internal:=true,
+ com.ibm.icu.impl.data;x-internal:=true,
+ com.ibm.icu.impl.data.icudt38b;x-internal:=true,
+ com.ibm.icu.impl.data.icudt38b.brkitr;x-internal:=true,
+ com.ibm.icu.impl.data.icudt38b.coll;x-internal:=true,
+ com.ibm.icu.impl.data.icudt38b.rbnf;x-internal:=true,
+ com.ibm.icu.impl.data.icudt38b.translit;x-internal:=true
+Eclipse-LazyStart: true
+Bundle-ClassPath: .
+Eclipse-ExtensibleAPI: true
diff --git a/dev-java/icu4j/icu4j-3.8.1-r1.ebuild b/dev-java/icu4j/icu4j-3.8.1-r1.ebuild
new file mode 100644
index 0000000..509a9ba
--- /dev/null
+++ b/dev-java/icu4j/icu4j-3.8.1-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/icu4j-3.8.1-r1.ebuild,v 1.4 2008/08/24 16:03:21 nixnut Exp $
+
+# We currently download the Javadoc documentation.
+# It could optionally be built using the Ant build file.
+# testdata.jar and icudata.jar do not contain *.class files but *.res files
+# These *.res data files are needed to built the final jar
+# They do not need to be installed however as they will already be present in icu4j.jar
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2 java-osgi
+
+DESCRIPTION="ICU4J is a set of Java libraries providing Unicode and Globalization support."
+MY_PV=${PV//./_}
+
+SRC_URI="http://download.icu-project.org/files/${PN}/${PV}/${PN}-${MY_PV}-src.jar
+ doc? ( http://download.icu-project.org/files/${PN}/${PV}/${PN}-${MY_PV}-docs.jar )"
+
+HOMEPAGE="http://www.icu-project.org/"
+LICENSE="icu"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc ppc64 x86 ~x86-fbsd"
+
+RDEPEND=">=virtual/jre-1.4"
+
+# build.xml does file version detection that fails for 1.7
+# http://bugs.gentoo.org/show_bug.cgi?id=213555
+DEPEND="test? ( || ( =virtual/jdk-1.5* =virtual/jdk-1.4* ) )
+ !test? ( || ( =virtual/jdk-1.6* =virtual/jdk-1.5* =virtual/jdk-1.4* ) )
+ app-arch/unzip"
+
+IUSE="doc test"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ jar -xf "${DISTDIR}/${PN}-${MY_PV}-src.jar" || die "Failed to unpack"
+
+ if use doc; then
+ mkdir docs; cd docs
+ jar -xf "${DISTDIR}/${PN}-${MY_PV}-docs.jar" || die "Failed to unpack docs"
+ fi
+}
+
+src_compile() {
+ # Classes extending CharsetICU not implementing Comparable
+ # Breaks with ecj on jdk 1.5+, javac doesn't mind - Sun's hack?
+ # Restricting to javac (didn't even care to try jikes) is better
+ # than forcing 1.4
+ java-pkg_force-compiler javac
+ eant jar || die "Compile failed"
+}
+
+src_install() {
+ java-osgi_newjar-fromfile --no-auto-version "${PN}.jar" "${FILESDIR}/icu4j-${PV}-manifest" \
+ "International Components for Unicode for Java (ICU4J)"
+ java-pkg_dojar "${PN}-charsets.jar"
+
+ use doc && dohtml -r readme.html docs/*
+ use source && java-pkg_dosrc src/*
+}
+
+# Following tests will fail in Sun JDK 6 (at least):
+# toUnicode: http://bugs.icu-project.org/trac/ticket/5663
+# TimeZoneTransitionAdd: http://bugs.icu-project.org/trac/ticket/5887
+# These are bugs in the tests themselves, not in the library
+
+src_test() {
+ # Tests currently fail, disabled for now. Need to investigate (tests work in icu4j-4.0)
+ #eant check
+ einfo "Tests currently disabled."
+}