summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2023-07-16 12:38:49 +0100
committerMarc Schiffbauer <mschiff@gentoo.org>2023-07-16 13:58:56 +0100
commite226fcc900914f82098a4be3c430a9c05d987242 (patch)
tree0b46fd74ea43acaed8100de85dc9ba89024524d3 /app-editors/logseq-desktop-bin/logseq-desktop-bin-0.9.10.ebuild
parentwww-apps/isso: add 0.13.0, drop 0.12.5 (diff)
downloadmschiff-e226fcc900914f82098a4be3c430a9c05d987242.tar.gz
mschiff-e226fcc900914f82098a4be3c430a9c05d987242.tar.bz2
mschiff-e226fcc900914f82098a4be3c430a9c05d987242.zip
app-editors/logseq-desktop-bin: added ebuild
Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
Diffstat (limited to 'app-editors/logseq-desktop-bin/logseq-desktop-bin-0.9.10.ebuild')
-rw-r--r--app-editors/logseq-desktop-bin/logseq-desktop-bin-0.9.10.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-editors/logseq-desktop-bin/logseq-desktop-bin-0.9.10.ebuild b/app-editors/logseq-desktop-bin/logseq-desktop-bin-0.9.10.ebuild
new file mode 100644
index 0000000..dd37b38
--- /dev/null
+++ b/app-editors/logseq-desktop-bin/logseq-desktop-bin-0.9.10.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop unpacker
+
+DESCRIPTION="A privacy-first, open-source platform for knowledge sharing and management."
+HOMEPAGE="https://github.com/logseq/logseq"
+SRC_URI="https://github.com/logseq/logseq/releases/download/${PV}/logseq-linux-x64-${PV}.zip -> ${P}.zip"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RESTRICT="mirror splitdebug"
+
+DEPEND=""
+RDEPEND=""
+BDEPEND="app-arch/unzip"
+
+QA_PREBUILT="*"
+S="${WORKDIR}/Logseq-linux-x64"
+
+src_install() {
+ domenu "${FILESDIR}/logseq-desktop.desktop"
+ doicon "${S}/resources/app/icons/logseq.png"
+ mkdir -p "${D}/opt/logseq-desktop" || die
+ cp -r "${S}"/* "${D}/opt/logseq-desktop/" || die
+ dosym ../logseq-desktop/Logseq /opt/bin/logseq
+}
+
+pkg_postinst() {
+ update-desktop-database
+}