summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/xmlrpc-epi/xmlrpc-epi-0.51.ebuild')
-rw-r--r--dev-libs/xmlrpc-epi/xmlrpc-epi-0.51.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/xmlrpc-epi/xmlrpc-epi-0.51.ebuild b/dev-libs/xmlrpc-epi/xmlrpc-epi-0.51.ebuild
new file mode 100644
index 0000000..2d67c80
--- /dev/null
+++ b/dev-libs/xmlrpc-epi/xmlrpc-epi-0.51.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit autotools eutils
+
+DESCRIPTION=""
+HOMEPAGE="http://xmlrpc-epi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xmlrpc-epi/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-devel/gettext
+ !dev-libs/xmlrpc-c"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-64bit-fixes.patch
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+ epatch "${FILESDIR}"/${P}-expat.patch
+ epatch "${FILESDIR}"/${P}-secondlife.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}