summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMATSUU Takuto <matsuu@gentoo.org>2009-04-24 00:25:08 +0900
committerMATSUU Takuto <matsuu@gentoo.org>2009-04-24 00:25:08 +0900
commit68b7371a5c3a67c8c10287b94730039afbacf656 (patch)
tree249978875353f120da6d69c93f370a53c09f9cbf /dev-db
parentx11-wm/awesome: Fixed USE=doc issue. (diff)
downloadmatsuu-68b7371a5c3a67c8c10287b94730039afbacf656.tar.gz
matsuu-68b7371a5c3a67c8c10287b94730039afbacf656.tar.bz2
matsuu-68b7371a5c3a67c8c10287b94730039afbacf656.zip
dev-db/tokyocabinet: initial import.
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/tokyocabinet/Manifest2
-rw-r--r--dev-db/tokyocabinet/tokyocabinet-1.4.16.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-db/tokyocabinet/Manifest b/dev-db/tokyocabinet/Manifest
new file mode 100644
index 0000000..bed014f
--- /dev/null
+++ b/dev-db/tokyocabinet/Manifest
@@ -0,0 +1,2 @@
+DIST tokyocabinet-1.4.16.tar.gz 891358 RMD160 d8f7f7e6273d4c261519f121bdf6ac0a488fee2e SHA1 a6bce136d52a3041847df719c2e0b70df4e14b61 SHA256 8769f80d5a4500bbec94edad56e4ad0a2585f2d269235f84a49707a256700097
+EBUILD tokyocabinet-1.4.16.ebuild 849 RMD160 26fc14681be65b64524eba40d3231c00d957319c SHA1 f1246f9f9a2e6ded1d705acbb6647496534f7178 SHA256 9c9b02951f2449887f932b383b60bd9907d16e8491ec52020bdf7840828c0296
diff --git a/dev-db/tokyocabinet/tokyocabinet-1.4.16.ebuild b/dev-db/tokyocabinet/tokyocabinet-1.4.16.ebuild
new file mode 100644
index 0000000..839d9b6
--- /dev/null
+++ b/dev-db/tokyocabinet/tokyocabinet-1.4.16.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="A high performance database library similar to the DBM family"
+HOMEPAGE="http://sourceforge.net/projects/tokyocabinet/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 lzma lzo threads zlib"
+
+DEPEND="bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/lzma )
+ lzo? ( dev-libs/lzo )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf \
+ $(use_enable bzip2 bzip) \
+ $(use_enable lzma exlzma) \
+ $(use_enable lzo exlzo) \
+ $(use_enable threads pthread) \
+ $(use_enable zlib) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc ChangeLog README THANKS || die
+ dohtml doc/* || die
+}