summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5-r1.ebuild')
-rw-r--r--hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5-r1.ebuild20
1 files changed, 4 insertions, 16 deletions
diff --git a/hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5-r1.ebuild b/hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5-r1.ebuild
index 8de05e0..f2b2b87 100644
--- a/hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5-r1.ebuild
+++ b/hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.5-r1.ebuild,v 1.2 2007/03/13 08:23:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.5-r1.ebuild,v 1.3 2007/03/15 16:09:05 kevquinn Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -224,6 +224,7 @@ toolchain-glibc_src_unpack() {
gcc-specs-pie && epatch "${FILESDIR}"/2.5/glibc-2.5-hardened-pie.patch
epatch "${FILESDIR}"/2.5/glibc-2.5-hardened-configure-picdefault.patch
epatch "${FILESDIR}"/2.5/glibc-2.5-hardened-inittls-nosysenter.patch
+ epatch "${FILESDIR}"/glibc-respect-env-CPPFLAGS.patch
einfo "Installing Hardened Gentoo SSP handler"
cp -f "${FILESDIR}"/2.5/glibc-2.5-gentoo-stack_chk_fail.c \
@@ -244,18 +245,6 @@ toolchain-glibc_src_unpack() {
-e 's:-fstack-protector$:-fstack-protector-all:' \
nscd/Makefile \
|| die "Failed to ensure nscd builds with ssp-all"
-
-# # Fixup use of PIC to choose PIC variants when built -fPIE.
-# # Prepends all files that have "#ifdef PIC" or similar, with
-# # preprocessor macros to define PIC if the compiler has
-# # defined __PIC__.
-# find ${S} -name '*.[h|S]' | \
-# xargs grep -l '^[[:space:]]*#[[:space:]]*if.*\bPIC\b' | \
-# xargs sed -i -e '1i#if defined __PIC__ && !defined PIC\
-## define PIC\
-##endif\
-#'
-
fi
gnuconfig_update
@@ -737,10 +726,9 @@ setup_flags() {
filter-flags -fstack-protector
if use hardened && gcc-specs-pie ; then
- # Force PIC macro definition for all compilations, since they're all
+ # Force PIC macro definition for all compilations since they're all
# either -fPIC or -fPIE with the default-PIE compiler.
- append-flags -DPIC
- export ASFLAGS="${ASFLAGS} -DPIC"
+ export CPPFLAGS="${CPPFLAGS} -DPIC"
else
# Don't build -fPIE without the default-PIE compiler and the
# hardened-pie patch