summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2007-02-09 17:52:28 +0000
committerRobert Buchholz <rbu@gentoo.org>2007-02-09 17:52:28 +0000
commit5cf6df2ad4095e680c2f69a29835ae356958ce07 (patch)
tree47cf13d745e72a30af3294854818669af53d1227 /app-misc/lcd-linux/lcd-linux-0.12.0.ebuild
parentRemove in-tree stuff (diff)
downloadjokey-5cf6df2ad4095e680c2f69a29835ae356958ce07.tar.gz
jokey-5cf6df2ad4095e680c2f69a29835ae356958ce07.tar.bz2
jokey-5cf6df2ad4095e680c2f69a29835ae356958ce07.zip
app-misc/lcd-linux: Initial commit
svn path=/trunk/; revision=118
Diffstat (limited to 'app-misc/lcd-linux/lcd-linux-0.12.0.ebuild')
-rw-r--r--app-misc/lcd-linux/lcd-linux-0.12.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-misc/lcd-linux/lcd-linux-0.12.0.ebuild b/app-misc/lcd-linux/lcd-linux-0.12.0.ebuild
new file mode 100644
index 0000000..7e5283a
--- /dev/null
+++ b/app-misc/lcd-linux/lcd-linux-0.12.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit linux-mod eutils
+
+DESCRIPTION="LCD-Linux is a Linux software abstraction layer to drive LCD alphanumeric displays. It features complete VT102 console emulation."
+HOMEPAGE="http://lcd-linux.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+DEPEND="sys-kernel/linux-headers"
+RDEPEND=""
+
+# linux-mod variables
+BUILD_TARGETS="install"
+BUILD_PARAMS="DESTROOT=${D} KERNEL_VERSION=${KV_FULL}"
+MODULE_NAMES="lcd-linux(misc:${S}:modules) hd44780(misc:${S}:modules)"
+# CONFIG_CHECK="USB VIDEO_V4L1_COMPAT !USB_PWC"
+# ERROR_USB="${P} requires Host-side USB support (CONFIG_USB)."
+# ERROR_USB_PWC="${P} requires the in-kernel version of the PWC driver to be disabled (CONFIG_USB_PWC)."
+# ERROR_VIDEO_V4L1_COMPAT="{$P} requires support for the Video For Linux API 1 compatibility layer (CONFIG_VIDEO_V4L1_COMPAT)."
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+}
+
+src_compile() {
+ mkdir -p ${D}/lib/modules/${KV_FULL}/build/include/linux
+
+ linux-mod_src_compile;
+
+}