aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-03-22 21:23:40 +0100
committerJohannes Huber <johu@gentoo.org>2018-03-22 21:23:40 +0100
commit2a95918bf7c16dcd7a4b4b6bdeadb01205b7b5f3 (patch)
treee8e0988e4c8e67281c889e01830cf73fa2c196ca
parentmedia-sound/tomahawk: Sync w/ tree (diff)
downloadjohu-2a95918bf7c16dcd7a4b4b6bdeadb01205b7b5f3.tar.gz
johu-2a95918bf7c16dcd7a4b4b6bdeadb01205b7b5f3.tar.bz2
johu-2a95918bf7c16dcd7a4b4b6bdeadb01205b7b5f3.zip
net-irc/quassel: Sync w/ tree
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--net-irc/quassel/files/quasselcore.conf-r1 (renamed from net-irc/quassel/files/quasselcore.conf)10
-rw-r--r--net-irc/quassel/files/quasselcore.init62
-rw-r--r--net-irc/quassel/files/quasselcore.init-r122
-rw-r--r--net-irc/quassel/quassel-9999.ebuild39
4 files changed, 47 insertions, 86 deletions
diff --git a/net-irc/quassel/files/quasselcore.conf b/net-irc/quassel/files/quasselcore.conf-r1
index f8d847b..280ca52 100644
--- a/net-irc/quassel/files/quasselcore.conf
+++ b/net-irc/quassel/files/quasselcore.conf-r1
@@ -2,7 +2,6 @@
# Distributed under the terms of the GNU General Public License v2
# Loglevel Debug|Info|Warning|Error. Default is: Info
-# The logfile is located at /var/log/quassel.log.
#LOGLEVEL="Info"
# The address(es) quasselcore will listen on. Default is 0.0.0.0
@@ -10,12 +9,3 @@
# The port quasselcore will listen at. Default is: 4242
#PORT="4242"
-
-# User we want our daemon to run under.
-#QUASSEL_USER="quassel"
-
-# Directory we store all quasselcore content.
-#CONFIGDIR="/var/lib/quassel"
-
-# File quasselcore will log all its events into.
-#LOGFILE="/var/log/quassel.log"
diff --git a/net-irc/quassel/files/quasselcore.init b/net-irc/quassel/files/quasselcore.init
deleted file mode 100644
index b58f6e7..0000000
--- a/net-irc/quassel/files/quasselcore.init
+++ /dev/null
@@ -1,62 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- need localmount net
- after bootmisc postgres
-}
-
-CORE="$(which quasselcore)"
-PID="/var/run/quassel.pid"
-LOGFILE=${LOGFILE:-"/var/log/quassel.log"}
-CONFIGDIR=${CONFIGDIR:-"/var/lib/quassel"}
-QUASSEL_USER=${QUASSEL_USER:-"quassel"}
-
-checkconfig() {
- # set defaults
- LOGLEVEL=${LOGLEVEL:-"Info"}
-
- # check config folder
- if [ ! -d "${CONFIGDIR}" ]; then
- mkdir "${CONFIGDIR}" || return 1
- fi
- # permissions always changed just to avoid runtime issues
- chown -R "${QUASSEL_USER}":"${QUASSEL_USER}" "${CONFIGDIR}" || return 1
-
- # check log file
- if [ ! -e "${LOGFILE}" ]; then
- touch "${LOGFILE}" || return 1
- fi
- # permissions always changed just to avoid runtime issues
- chown "${QUASSEL_USER}":"${QUASSEL_USER}" "${LOGFILE}" || return 1
-}
-
-start() {
- checkconfig || return 1
-
- ebegin "Starting Quassel Core"
-
- if [ -n "${RC_UNAME}" ]; then
- # running on baselayout-2/openrc
- start-stop-daemon --start --user "${QUASSEL_USER}" --background --make-pidfile \
- --pidfile "${PID}" \
- --exec "${CORE}" -- --logfile="${LOGFILE}" --loglevel="${LOGLEVEL}" \
- ${LISTEN:+--listen="${LISTEN}"} ${PORT:+--port="${PORT}"} \
- --configdir="${CONFIGDIR}"
- else
- # running on baselayout-1
- start-stop-daemon --start --chuid "${QUASSEL_USER}" --background --make-pidfile \
- --pidfile "${PID}" --env HOME="${CONFIGDIR}" \
- --exec "${CORE}" -- --logfile="${LOGFILE}" --loglevel="${LOGLEVEL}" \
- ${LISTEN:+--listen="${LISTEN}"} ${PORT:+--port="${PORT}"} \
- --configdir="${CONFIGDIR}"
- fi
- eend $?
-}
-
-stop() {
- ebegin "Stopping Quassel Core"
- start-stop-daemon --stop --pidfile "${PID}" --exec "${CORE}"
- eend $?
-}
diff --git a/net-irc/quassel/files/quasselcore.init-r1 b/net-irc/quassel/files/quasselcore.init-r1
new file mode 100644
index 0000000..cfcb5db
--- /dev/null
+++ b/net-irc/quassel/files/quasselcore.init-r1
@@ -0,0 +1,22 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ after logger postgresql
+}
+
+LISTEN=${LISTEN:-"0.0.0.0"}
+LOGLEVEL=${LOGLEVEL:-"Info"}
+PORT=${PORT:="4242"}
+
+command="/usr/bin/quasselcore"
+command_args="--configdir=/var/lib/quassel
+ --listen=${LISTEN}
+ --loglevel=${LOGLEVEL}
+ --port=${PORT}
+ --syslog"
+command_background="yes"
+command_user="quassel"
+description="Quassel Core"
+pidfile="/run/quassel.pid"
diff --git a/net-irc/quassel/quassel-9999.ebuild b/net-irc/quassel/quassel-9999.ebuild
index ede96d6..1f9e3e1 100644
--- a/net-irc/quassel/quassel-9999.ebuild
+++ b/net-irc/quassel/quassel-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit cmake-utils eutils pax-utils systemd user
+inherit cmake-utils gnome2-utils pax-utils systemd user
EGIT_REPO_URI=( "https://github.com/${PN}/${PN}" "git://git.${PN}-irc.org/${PN}" )
[[ "${PV}" == "9999" ]] && inherit git-r3
@@ -13,13 +13,15 @@ HOMEPAGE="http://quassel-irc.org/"
[[ "${PV}" == "9999" ]] || SRC_URI="http://quassel-irc.org/pub/${P}.tar.bz2"
LICENSE="GPL-3"
-SLOT="0"
KEYWORDS=""
-IUSE="+breeze crypt +dbus debug kde monolithic oxygen postgres +server snorenotify +ssl syslog urlpreview X"
+SLOT="0"
+IUSE="+breeze crypt +dbus debug kde ldap monolithic oxygen postgres +server
+snorenotify +ssl syslog urlpreview X"
SERVER_RDEPEND="
dev-qt/qtscript:5
- crypt? ( app-crypt/qca:2[qt5,ssl] )
+ crypt? ( app-crypt/qca:2[qt5(+),ssl] )
+ ldap? ( net-nds/openldap )
postgres? ( dev-qt/qtsql:5[postgres] )
!postgres? ( dev-qt/qtsql:5[sqlite] dev-db/sqlite:3[threadsafe(+),-secure-delete] )
syslog? ( virtual/logger )
@@ -50,9 +52,9 @@ GUI_RDEPEND="
"
RDEPEND="
- sys-libs/zlib
dev-qt/qtcore:5
dev-qt/qtnetwork:5[ssl?]
+ sys-libs/zlib
monolithic? (
${SERVER_RDEPEND}
${GUI_RDEPEND}
@@ -72,7 +74,8 @@ DOCS=( AUTHORS ChangeLog README.md )
REQUIRED_USE="
|| ( X server monolithic )
crypt? ( || ( server monolithic ) )
- kde? ( || ( X monolithic ) )
+ kde? ( || ( X monolithic ) dbus )
+ ldap? ( || ( server monolithic ) )
monolithic? ( || ( breeze oxygen ) )
postgres? ( || ( server monolithic ) )
snorenotify? ( || ( X monolithic ) )
@@ -94,20 +97,22 @@ src_configure() {
local mycmakeargs=(
-DUSE_QT4=OFF
-DUSE_QT5=ON
- -DWANT_CORE=$(usex server)
- -DWANT_MONO=$(usex monolithic)
- -DWANT_QTCLIENT=$(usex X)
- -DWITH_KDE=$(usex kde)
- -DWITH_WEBKIT=OFF
- -DWITH_WEBENGINE=$(usex urlpreview)
-DWITH_BREEZE=OFF
+ -DWITH_WEBKIT=OFF
-DWITH_BREEZE_DARK=OFF
-DWITH_OXYGEN=OFF
-DEMBED_DATA=OFF
-DCMAKE_SKIP_RPATH=ON
$(cmake-utils_use_find_package crypt QCA2-QT5)
$(cmake-utils_use_find_package dbus dbusmenu-qt5)
+ $(cmake-utils_use_find_package dbus Qt5DBus)
+ -DWITH_KDE=$(usex kde)
+ -DWITH_LDAP=$(usex ldap)
+ -DWANT_MONO=$(usex monolithic)
+ -DWANT_CORE=$(usex server)
$(cmake-utils_use_find_package snorenotify LibsnoreQt5)
+ -DWITH_WEBENGINE=$(usex urlpreview)
+ -DWANT_QTCLIENT=$(usex X)
)
cmake-utils_src_configure
@@ -125,8 +130,8 @@ src_install() {
fowners "${QUASSEL_USER}":"${QUASSEL_USER}" "${QUASSEL_DIR}"
# init scripts & systemd unit
- newinitd "${FILESDIR}"/quasselcore.init quasselcore
- newconfd "${FILESDIR}"/quasselcore.conf quasselcore
+ newinitd "${FILESDIR}"/quasselcore.init-r1 quasselcore
+ newconfd "${FILESDIR}"/quasselcore.conf-r1 quasselcore
systemd_dounit "${FILESDIR}"/quasselcore.service
# logrotate
@@ -150,6 +155,12 @@ pkg_postinst() {
einfo "Quassel can use net-misc/oidentd package if installed on your system."
einfo "Consider installing it if you want to run quassel within identd daemon."
fi
+
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
}
pkg_config() {