summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-12-24 18:44:20 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-12-24 18:44:20 +0000
commitfc6921620a1269d640b19dd1273749598b0463dd (patch)
tree338c746e3f0110d7218e720cedb86e98b3421d02
parentadd new stratagus, does not work for me yet (diff)
downloadgenstef-fc6921620a1269d640b19dd1273749598b0463dd.tar.gz
genstef-fc6921620a1269d640b19dd1273749598b0463dd.tar.bz2
genstef-fc6921620a1269d640b19dd1273749598b0463dd.zip
wargus fitting for new stratagus, not working error: Can't open file 'preferences.lua': No such file or directory
svn path=/; revision=93
-rw-r--r--games-strategy/wargus/wargus-2.2_beta.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-strategy/wargus/wargus-2.2_beta.ebuild b/games-strategy/wargus/wargus-2.2_beta.ebuild
new file mode 100644
index 0000000..d05ceed
--- /dev/null
+++ b/games-strategy/wargus/wargus-2.2_beta.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2004-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wargus/wargus-2.1-r1.ebuild,v 1.5 2006/10/24 23:06:43 wolf31o2 Exp $
+
+inherit eutils games
+
+DESCRIPTION="Warcraft II for the Stratagus game engine (Needs WC2 DOS CD)"
+HOMEPAGE="http://wargus.sf.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P/_}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="media-libs/libpng
+ sys-libs/zlib"
+RDEPEND="=games-engines/stratagus-${PV:0:3}*"
+S="${WORKDIR}/${P/_}"
+
+src_unpack() {
+ cdrom_get_cds data/rezdat.war
+ unpack ${A}
+}
+
+src_install() {
+ local dir="${GAMES_DATADIR}/stratagus/${PN}"
+ dodir "${dir}"
+ ./build.sh -p "${CDROM_ROOT}" -o "${D}/${dir}" -v \
+ || die "Failed to extract data"
+ games_make_wrapper wargus "./stratagus -d \"${dir}\"" "${GAMES_BINDIR}"
+ prepgamesdirs
+
+ doicon contrib/wargus.png
+ make_desktop_entry wargus Wargus
+}