summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2024-01-21 15:03:36 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2024-01-21 15:03:36 +0100
commitf3109104b8c0b8827b33ccc040784f53336260fb (patch)
tree9a7d1650ffc331dc9b28a13f59ba2fb10b82f8b6
parentdev-python/identify: superseded by gentoo repository (diff)
downloadeva-f3109104b8c0b8827b33ccc040784f53336260fb.tar.gz
eva-f3109104b8c0b8827b33ccc040784f53336260fb.tar.bz2
eva-f3109104b8c0b8827b33ccc040784f53336260fb.zip
app-backup/restic-rest-server: new package, add 0.12.1
Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
-rw-r--r--app-backup/restic-rest-server/Manifest2
-rw-r--r--app-backup/restic-rest-server/restic-rest-server-0.12.1.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/app-backup/restic-rest-server/Manifest b/app-backup/restic-rest-server/Manifest
new file mode 100644
index 0000000..48e3f97
--- /dev/null
+++ b/app-backup/restic-rest-server/Manifest
@@ -0,0 +1,2 @@
+DIST restic-rest-server-0.12.1-deps.tar.xz 11805964 BLAKE2B e3f909ac026bcd2bb869452bd06b8c3a89d25b0a67c32775b742c5907d79a8190f174c4f61ef5d5bcd9ade49366dbf9176deb6bd3e5f59427c9b7f107ed32b4b SHA512 d40fb86604b4440e61dbf1989347537939a64f8b56ba09400763d134f1935e3f7c5e91e4c4d96a9f0a324762845094d6fd02917a542ba9efe276685df442ccdf
+DIST restic-rest-server-0.12.1.tar.gz 281233 BLAKE2B 52400755fb4986659f529f416588f45ec64e1d546c6a8d07bc239bbf0dc779d4740e28cf99525fb4e1276e49564efe663819b50f4e16b657301c313d13975504 SHA512 113a1b310845bafe92fc4ee60aadd0f0dc8c5f4f1676706c89c48e291937c616ee33b57febd7a41d99dc57adb250e7f34de1c302cf685a44f009585acaccde44
diff --git a/app-backup/restic-rest-server/restic-rest-server-0.12.1.ebuild b/app-backup/restic-rest-server/restic-rest-server-0.12.1.ebuild
new file mode 100644
index 0000000..582359b
--- /dev/null
+++ b/app-backup/restic-rest-server/restic-rest-server-0.12.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd
+
+DESCRIPTION="high performance HTTP server that implements restic's REST backend API"
+HOMEPAGE="https://github.com/restic/rest-server"
+SRC_URI="https://github.com/restic/rest-server/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://www.whyte.ninja/pub/${P}-deps.tar.xz"
+S="${WORKDIR}/rest-server-${PV}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_compile() {
+ local mygoargs=(
+ -tags release
+ -ldflags "-X main.version=${PV}"
+ -asmflags "-trimpath=${S}"
+ -gcflags "-trimpath=${S}"
+ )
+
+ ego build "${mygoargs[@]}" -o rest-server ./cmd/rest-server
+}
+
+src_install() {
+ dobin rest-server
+ dodoc AUTHORS CHANGELOG.md README.md
+ # TODO: install systemd unit/socket
+}