summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/imspector/imspector-0.3.ebuild')
-rw-r--r--net-analyzer/imspector/imspector-0.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-analyzer/imspector/imspector-0.3.ebuild b/net-analyzer/imspector/imspector-0.3.ebuild
new file mode 100644
index 0000000..7d69ef9
--- /dev/null
+++ b/net-analyzer/imspector/imspector-0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Instant Messenger transparent proxy with logging capabilities."
+HOMEPAGE="http://www.imspector.org/"
+SRC_URI="http://www.imspector.org/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i -e 's/^CXXFLAGS =.*/CXXFLAGS += -fPIC/' "${S}"/Makefile
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" || die 'emake failed'
+}