aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/rdkit/rdkit-2010.2.1.ebuild')
-rw-r--r--sci-chemistry/rdkit/rdkit-2010.2.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-chemistry/rdkit/rdkit-2010.2.1.ebuild b/sci-chemistry/rdkit/rdkit-2010.2.1.ebuild
new file mode 100644
index 0000000..e3a4984
--- /dev/null
+++ b/sci-chemistry/rdkit/rdkit-2010.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+CMAKE_MIN_VERSION=2.8
+
+inherit cmake-utils versionator
+
+MAJOR_V=$(get_version_component_range 1)
+Q_V=$(get_version_component_range 2)
+MICRO_V=$(get_version_component_range 3)
+MY_P="RDKit_Q${Q_V}${MAJOR_V}_${MICRO_V}"
+
+DESCRIPTION="www.rdkit.org/"
+HOMEPAGE="A software suite for cheminformatics, computational chemistry, and predictive modeling"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
+LICENSE="BSD-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RDEPEND=">=dev-lang/python-2.5
+ dev-db/sqlite:3
+ dev-python/numpy
+ dev-python/imaging
+ dev-python/matplotlib
+ dev-python/aggdraw
+ >=dev-libs/boost-1.40"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison"
+S=${WORKDIR}/${MY_P}
+
+src_test() {
+ pushd ${CMAKE_BUILD_DIR} >/dev/null
+ sqlite3 ../Data/RDTests.sqlt < ../rdkit/Dbase/test_data/RDTests.sqlite || die
+ sqlite3 ../Data/RDData.sqlt < ../rdkit/Dbase/test_data/RDData.sqlite || die
+ ctest || die "Tests failed"
+ popd >/dev/null
+}