aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <donnie@supernova.(none)>2006-09-03 23:42:56 -0700
committerDonnie Berkholz <dberkholz@gentoo.org>2006-09-03 23:42:56 -0700
commit41969103d2789cb0d0bc2afa52da17db3f539bd3 (patch)
tree13296497bf13b1742d92342ad333bb9ec69b5726 /app-admin
parentsystem-config-bind: remove artifact of a gettext bug. (diff)
downloaddberkholz-41969103d2789cb0d0bc2afa52da17db3f539bd3.tar.gz
dberkholz-41969103d2789cb0d0bc2afa52da17db3f539bd3.tar.bz2
dberkholz-41969103d2789cb0d0bc2afa52da17db3f539bd3.zip
Add system-config-users. Doesn't seem to detect groups properly yet.
This appears to be because MEMBERUID is blank, at least in the wheel group.
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/system-config-users/Manifest12
-rw-r--r--app-admin/system-config-users/files/1.2.46-remove-rpm-use.patch48
-rw-r--r--app-admin/system-config-users/files/digest-system-config-users-1.2.463
-rw-r--r--app-admin/system-config-users/system-config-users-1.2.46.ebuild43
4 files changed, 106 insertions, 0 deletions
diff --git a/app-admin/system-config-users/Manifest b/app-admin/system-config-users/Manifest
new file mode 100644
index 0000000..92687af
--- /dev/null
+++ b/app-admin/system-config-users/Manifest
@@ -0,0 +1,12 @@
+AUX 1.2.46-remove-rpm-use.patch 1822 RMD160 a6d140d33e8e5d787fd8cee4fa14d11acf6d662d SHA1 db8bcb2a82ab02a7233da13e7d6fb3d1a9874e4f SHA256 8a699e8dc0a21dd3244cb84fc96a5d28df2cb07099e2985226a6971a4539ef90
+MD5 30859db7251b99cd75a84ef4e457d9ca files/1.2.46-remove-rpm-use.patch 1822
+RMD160 a6d140d33e8e5d787fd8cee4fa14d11acf6d662d files/1.2.46-remove-rpm-use.patch 1822
+SHA256 8a699e8dc0a21dd3244cb84fc96a5d28df2cb07099e2985226a6971a4539ef90 files/1.2.46-remove-rpm-use.patch 1822
+DIST system-config-users-1.2.46-1.fc6.src.rpm 289754 RMD160 29ea89df633af60e087c1545e0872ef4d9e5b017 SHA1 e01e60691976d4f77feda40a1ba7014146522a62 SHA256 79e24cc897cdf35fa3d5b4cf3f996a27a346a488f3ded886ff35962b13517389
+EBUILD system-config-users-1.2.46.ebuild 1025 RMD160 b8fd9a1003fcbe38383354c000a7977be3f6328d SHA1 8c4bc197c4f42b5784009ebee70e6eb1f7767183 SHA256 e08fe87d02255f71c9691265cc9a1d1db0d10b17a3de7c8d780eae3403a49dd9
+MD5 de78ce148ee5260010a70b08ea172924 system-config-users-1.2.46.ebuild 1025
+RMD160 b8fd9a1003fcbe38383354c000a7977be3f6328d system-config-users-1.2.46.ebuild 1025
+SHA256 e08fe87d02255f71c9691265cc9a1d1db0d10b17a3de7c8d780eae3403a49dd9 system-config-users-1.2.46.ebuild 1025
+MD5 e7831136467ad58c53b6dfc7e9e962e8 files/digest-system-config-users-1.2.46 301
+RMD160 30366633fa5397c2b5a050c1c25b70c5c1d7096b files/digest-system-config-users-1.2.46 301
+SHA256 69b060bc19cbf997b34a8529489d45f6ad9072a0008cdaa27865bdeb9bbfadb7 files/digest-system-config-users-1.2.46 301
diff --git a/app-admin/system-config-users/files/1.2.46-remove-rpm-use.patch b/app-admin/system-config-users/files/1.2.46-remove-rpm-use.patch
new file mode 100644
index 0000000..676c795
--- /dev/null
+++ b/app-admin/system-config-users/files/1.2.46-remove-rpm-use.patch
@@ -0,0 +1,48 @@
+Index: src/mainWindow.py
+===================================================================
+RCS file: /usr/local/CVS/redhat-config-users/src/mainWindow.py,v
+retrieving revision 1.118
+diff -u -b -B -r1.118 mainWindow.py
+--- src/mainWindow.py 13 Jul 2006 17:19:04 -0000 1.118
++++ src/mainWindow.py 4 Sep 2006 06:19:06 -0000
+@@ -26,7 +26,6 @@
+ import sys
+ import time
+ import os
+-import rpm
+
+ import libuser
+
+@@ -607,9 +606,6 @@
+ dlg.run ()
+ dlg.destroy ()
+ return
+- ts = rpm.TransactionSet ()
+- if ts.dbMatch ("basenames", homeDir).count () > 0 or ts.dbMatch ("basenames", os.path.abspath (homeDir)).count () > 0 or ts.dbMatch ("basenames", os.path.realpath (homeDir)).count () > 0:
+- errMsgs.append (_("- An installed software package contains this directory."))
+ if uid < 500 or (user == "nfsnobody" and (long (uid) == 65534L or long (uid) == 4294967294L)):
+ errMsgs.append (_("- A system user owns this directory and removing it may impair the system's integrity."))
+ if not os.access(homeDir, os.W_OK):
+@@ -856,21 +852,12 @@
+ self.on_properties_activate()
+
+ def isSELinuxInstalled(self):
+- ts = rpm.TransactionSet()
+-
+- mi = ts.dbMatch('name', 'policy-sources')
+- if mi.count() > 0:
+- return 1
+- return 0
++ return self.isSELinuxEnabled()
+
+ def isSELinuxEnabled(self):
+- if self.isSELinuxInstalled():
+ if os.system("/usr/bin/selinuxenabled") > 0:
+ #it's enabled, return 1
+ return 1
+ else:
+ #it's installed, but not enabled
+ return 0
+- else:
+- #not installed
+- return 0
diff --git a/app-admin/system-config-users/files/digest-system-config-users-1.2.46 b/app-admin/system-config-users/files/digest-system-config-users-1.2.46
new file mode 100644
index 0000000..3d39a6a
--- /dev/null
+++ b/app-admin/system-config-users/files/digest-system-config-users-1.2.46
@@ -0,0 +1,3 @@
+MD5 549f01d76e36c5f48031c020aa74303c system-config-users-1.2.46-1.fc6.src.rpm 289754
+RMD160 29ea89df633af60e087c1545e0872ef4d9e5b017 system-config-users-1.2.46-1.fc6.src.rpm 289754
+SHA256 79e24cc897cdf35fa3d5b4cf3f996a27a346a488f3ded886ff35962b13517389 system-config-users-1.2.46-1.fc6.src.rpm 289754
diff --git a/app-admin/system-config-users/system-config-users-1.2.46.ebuild b/app-admin/system-config-users/system-config-users-1.2.46.ebuild
new file mode 100644
index 0000000..f4029b2
--- /dev/null
+++ b/app-admin/system-config-users/system-config-users-1.2.46.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils rpm
+
+# Tag for which Fedora Core version it's from
+FCVER="6"
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="1"
+
+DESCRIPTION="A graphical interface for administering users and groups"
+HOMEPAGE="http://fedora.redhat.com/projects/config-tools/"
+SRC_URI="mirror://fedora/development/source/SRPMS/${P}-${RPMREV}.fc${FCVER}.src.rpm"
+LICENSE=""
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+RDEPEND="=dev-python/pygtk-2*
+ >=x11-libs/gtk+-2.6
+ dev-lang/python
+ sys-apps/usermode
+ www-client/htmlview
+ dev-python/rhpl
+ x11-themes/hicolor-icon-theme"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/intltool"
+
+src_unpack() {
+ rpm_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-remove-rpm-use.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ make_desktop_entry /usr/bin/${PN}
+
+ fperms 644 /etc/pam.d/${PN}
+}