summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/catalyst/catalyst-2.0.6.918.ebuild')
-rw-r--r--dev-util/catalyst/catalyst-2.0.6.918.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-util/catalyst/catalyst-2.0.6.918.ebuild b/dev-util/catalyst/catalyst-2.0.6.918.ebuild
deleted file mode 100644
index 43b7f9a..0000000
--- a/dev-util/catalyst/catalyst-2.0.6.918.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.6.918.ebuild,v 1.2 2011/07/17 00:29:56 mattst88 Exp $
-
-EAPI=4
-inherit eutils multilib
-
-DESCRIPTION="release metatool used for creating releases based on Gentoo Linux,
-with NFS patch"
-HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="ccache"
-
-DEPEND="app-text/asciidoc"
-RDEPEND="dev-lang/python
- app-crypt/shash
- virtual/cdrtools
- ccache? ( dev-util/ccache )
- ia64? ( sys-fs/dosfstools )
- kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
-
-src_prepare() {
- epatch "${FILESDIR}"/0001*.patch
-}
-
-src_install() {
- insinto /usr/$(get_libdir)/${PN}
- exeinto /usr/$(get_libdir)/${PN}
- doexe catalyst
- if [[ ${PV} == 9999* ]]; then
- doins -r modules files
- else
- doins -r arch modules livecd
- fi
- for x in targets/*; do
- exeinto /usr/$(get_libdir)/${PN}/$x
- doexe $x/*
- done
- make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
- insinto /etc/catalyst
- doins files/catalyst.conf files/catalystrc
- insinto /usr/share/doc/${PF}/examples
- doins examples/*
- dodoc README ChangeLog AUTHORS
- doman files/catalyst.1
- # Here is where we actually enable ccache
- use ccache && \
- dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
- /etc/catalyst/catalyst.conf
- dosed "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
- /etc/catalyst/catalyst.conf
-}