summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2011-11-28 16:28:50 +0000
committerJeremy Olexa <darkside@gentoo.org>2011-11-28 16:28:50 +0000
commit5e2c06613c05ad4f116cc8e1365a8f9297914492 (patch)
tree76f139ca4df5fe01a6f8d19dce41f17443e3ca27
parent[dev-util/catalyst] Do not use dosed with EAPI=4 (diff)
downloaddarkside-5e2c06613c05ad4f116cc8e1365a8f9297914492.tar.gz
darkside-5e2c06613c05ad4f116cc8e1365a8f9297914492.tar.bz2
darkside-5e2c06613c05ad4f116cc8e1365a8f9297914492.zip
[dev-util/catalyst] use if block
-rw-r--r--dev-util/catalyst/catalyst-2.0.7.1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-util/catalyst/catalyst-2.0.7.1.ebuild b/dev-util/catalyst/catalyst-2.0.7.1.ebuild
index 47fba61..de529f1 100644
--- a/dev-util/catalyst/catalyst-2.0.7.1.ebuild
+++ b/dev-util/catalyst/catalyst-2.0.7.1.ebuild
@@ -49,9 +49,9 @@ src_install() {
dodoc README ChangeLog AUTHORS
doman files/catalyst.1
# Here is where we actually enable ccache
- use ccache && \
- sed -i -e 's:options="autoresume kern:options="autoresume ccache kern:' \
- /etc/catalyst/catalyst.conf || die
+ if use ccache; then
+ sed -i -e 's:options="autoresume kern:options="autoresume ccache kern:' /etc/catalyst/catalyst.conf || die
+ fi
sed -i -e "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
/etc/catalyst/catalyst.conf || die
}