summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libassuan/libassuan-2.0.1.ebuild')
-rw-r--r--dev-libs/libassuan/libassuan-2.0.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/libassuan/libassuan-2.0.1.ebuild b/dev-libs/libassuan/libassuan-2.0.1.ebuild
new file mode 100644
index 0000000..c243081
--- /dev/null
+++ b/dev-libs/libassuan/libassuan-2.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libassuan/libassuan-2.0.0.ebuild,v 1.10 2011/01/12 16:07:18 flameeyes Exp $
+
+EAPI="2"
+
+DESCRIPTION="IPC library used by GnuPG and GPGME"
+HOMEPAGE="http://www.gnupg.org/related_software/libassuan/index.en.html"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-2.1"
+SLOT="0"
+KEYWORDS=""
+IUSE="static-libs"
+
+DEPEND=">=dev-libs/libgpg-error-1.8"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die
+}