summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/getent/getent-9999.ebuild')
-rw-r--r--sys-apps/getent/getent-9999.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/sys-apps/getent/getent-9999.ebuild b/sys-apps/getent/getent-9999.ebuild
index ca09397..6307204 100644
--- a/sys-apps/getent/getent-9999.ebuild
+++ b/sys-apps/getent/getent-9999.ebuild
@@ -6,11 +6,19 @@ EAPI="5"
DESCRIPTION="Script to emulate the behavior of glibc's getent utility"
HOMEPAGE="http://www.uclibc.org/"
-SRC_URI="http://git.uclibc.org/uClibc/plain/extra/scripts/${PN}"
+
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI="http://git.uclibc.org/uClibc/plain/extra/scripts/${PN}"
+ MY_P=${PN}
+else
+ SRC_URI="http://dev.gentoo.org/~blueness/${PN}/${P}"
+ KEYWORDS="~amd64 ~arm ~m68k ~mips ~ppc ~sh ~sparc ~x86"
+ MY_P=${P}
+fi
+
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~m68k ~mips ~ppc ~sh ~sparc ~x86"
DEPEND="
!sys-libs/glibc
@@ -19,7 +27,7 @@ DEPEND="
src_unpack() {
mkdir ${P}
- cp "${DISTDIR}"/${PN} ${P}
+ cp "${DISTDIR}"/${MY_P} ${P}/${PN}
}
src_install() {