summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-02-17 15:57:44 +0100
committerChristoph Mende <angelos@gentoo.org>2011-02-17 15:57:44 +0100
commitbf8d3a7cc9c361535e628b0e60f73951a857923e (patch)
treed39d4e24cc1c51d5d7767d7301821b6e9d575d47 /net-misc
downloadangelos-bf8d3a7cc9c361535e628b0e60f73951a857923e.tar.gz
angelos-bf8d3a7cc9c361535e628b0e60f73951a857923e.tar.bz2
angelos-bf8d3a7cc9c361535e628b0e60f73951a857923e.zip
Initial import
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/chaosvpn/Manifest4
-rw-r--r--net-misc/chaosvpn/chaosvpn-2.05.ebuild49
-rw-r--r--net-misc/chaosvpn/chaosvpn-9999.ebuild46
-rwxr-xr-xnet-misc/chaosvpn/files/chaosvpn.init30
-rw-r--r--net-misc/notifyserv/ChangeLog24
-rw-r--r--net-misc/notifyserv/Manifest16
-rw-r--r--net-misc/notifyserv/notifyserv-1.1.ebuild17
-rw-r--r--net-misc/notifyserv/notifyserv-2.0.ebuild17
-rw-r--r--net-misc/notifyserv/notifyserv-9999.ebuild27
9 files changed, 230 insertions, 0 deletions
diff --git a/net-misc/chaosvpn/Manifest b/net-misc/chaosvpn/Manifest
new file mode 100644
index 0000000..56b0511
--- /dev/null
+++ b/net-misc/chaosvpn/Manifest
@@ -0,0 +1,4 @@
+AUX chaosvpn.init 580 RMD160 d57bb636085467a0f91598422ffb860194e93aa0 SHA1 2ce1d74472c3e48108b7f120f1a35008c149a542 SHA256 7adb2e24f5f1063dcf6693928f7e27b3466f40bdaf4b7046b8b4ae70edb02623
+DIST chaosvpn-2.05.tar.gz 62457 RMD160 4ba0cdfe32b9cc51a4a32011abe5d96619acd090 SHA1 b33709b7b354e96c6cc12dff552664326184e994 SHA256 528724f7d6162b1b0d4509c9456d9d00248e5371f09b92a966f457cd14de964f
+EBUILD chaosvpn-2.05.ebuild 926 RMD160 d7933c01d81216344fed3267e767cf8131d1e143 SHA1 68845803ef3da06a992dfded420c41064a123f4e SHA256 b0f5b852f9ccfea570c96e0c19d379db64ebe2e31aef5cfa9da1eb5167d76767
+EBUILD chaosvpn-9999.ebuild 869 RMD160 253d7a992a54f6e13523439f75ca728b8ba640de SHA1 7ebe0cd181d3da6533b942ea7c645678bd9d664a SHA256 daba5bc7ddebab3eab07a205e6d6e6dc18733bfb726aef3ff37ebd6599dee47e
diff --git a/net-misc/chaosvpn/chaosvpn-2.05.ebuild b/net-misc/chaosvpn/chaosvpn-2.05.ebuild
new file mode 100644
index 0000000..eabcec9
--- /dev/null
+++ b/net-misc/chaosvpn/chaosvpn-2.05.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="ChaosVPN client"
+HOMEPAGE="http://wiki.hamburg.ccc.de/index.php/ChaosVPN"
+SRC_URI="https://github.com/ryd/${PN}/tarball/${PV} -> ${P}.tar.gz"
+REV=f1b4b62
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=net-misc/tinc-1.0.13"
+
+S=${WORKDIR}/ryd-${PN}-${REV}
+
+pkg_setup() {
+ enewuser chaosvpn "" "" /etc/tinc/chaos/
+}
+
+src_prepare() {
+ sed -i -e "/strip/d" Makefile || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ diropts -m0700 -o chaosvpn -g chaosvpn
+ dodir /etc/tinc/chaos/
+
+ newinitd "${FILESDIR}/${PN}.init" ${PN}
+}
+
+pkg_postinst() {
+ elog "Don't forget to run"
+ elog " # tincd -n chaos --generate-keys=2048"
+ elog "if this is your first install."
+}
diff --git a/net-misc/chaosvpn/chaosvpn-9999.ebuild b/net-misc/chaosvpn/chaosvpn-9999.ebuild
new file mode 100644
index 0000000..acb467d
--- /dev/null
+++ b/net-misc/chaosvpn/chaosvpn-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit eutils git toolchain-funcs
+
+DESCRIPTION="ChaosVPN client"
+HOMEPAGE="http://wiki.hamburg.ccc.de/index.php/ChaosVPN"
+EGIT_REPO_URI="git://github.com/ryd/chaosvpn.git"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=net-misc/tinc-1.0.13"
+
+pkg_setup() {
+ enewuser chaosvpn "" "" /etc/tinc/chaos/
+}
+
+src_prepare() {
+ sed -i -e "/strip/d" Makefile || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ diropts -m0700 -o chaosvpn -g chaosvpn
+ dodir /etc/tinc/chaos/
+
+ newinitd "${FILESDIR}/${PN}.init" ${PN}
+}
+
+pkg_postinst() {
+ elog "Don't forget to run"
+ elog " # tincd -n chaos --generate-keys=2048"
+ elog "if this is your first install."
+}
diff --git a/net-misc/chaosvpn/files/chaosvpn.init b/net-misc/chaosvpn/files/chaosvpn.init
new file mode 100755
index 0000000..2e64796
--- /dev/null
+++ b/net-misc/chaosvpn/files/chaosvpn.init
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+PIDFILE=/var/run/chaosvpn.pid
+opts="${opts} reload"
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting chaosvpn"
+ start-stop-daemon --start --quiet --background --pidfile ${PIDFILE} \
+ --exec /usr/sbin/chaosvpn -- -c /etc/tinc/chaosvpn.conf
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping chaosvpn"
+ start-stop-daemon --stop --quiet --pidfile ${PIDFILE}
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading chaosvpn config"
+ /usr/sbin/chaosvpn -o
+ eend $?
+}
diff --git a/net-misc/notifyserv/ChangeLog b/net-misc/notifyserv/ChangeLog
new file mode 100644
index 0000000..9312815
--- /dev/null
+++ b/net-misc/notifyserv/ChangeLog
@@ -0,0 +1,24 @@
+# ChangeLog for net-misc/notifyserv
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 01 Feb 2009; Christoph Mende <angelos@gentoo.org> notifyserv-9999.ebuild:
+ Need help2man when building from git
+
+*notifyserv-2.0 (26 Jan 2009)
+
+ 26 Jan 2009; Christoph Mende <angelos@gentoo.org> +notifyserv-2.0.ebuild:
+ Version bump
+
+*notifyserv-9999 (03 Dec 2008)
+*notifyserv-1.1 (03 Dec 2008)
+
+ 03 Dec 2008; Christoph Mende <angelos@gentoo.org> +notifyserv-1.1.ebuild,
+ +notifyserv-9999.ebuild:
+ Renamed to notifyserv
+
+*tickets-9999 (20 Nov 2008)
+
+ 20 Nov 2008; Christoph Mende <angelos@gentoo.org> +tickets-9999.ebuild:
+ git ebuild
+
diff --git a/net-misc/notifyserv/Manifest b/net-misc/notifyserv/Manifest
new file mode 100644
index 0000000..c118446
--- /dev/null
+++ b/net-misc/notifyserv/Manifest
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST notifyserv-2.0.tar.bz2 66576 RMD160 dbcf54bea75c5c53db79f45b046f99571fce9c59 SHA1 2ebb6f6d4d3c77c450c669e552b3d8063e397256 SHA256 81b9328096321720fba7738f2ac61cbcce5d27f0c4933afb75d9dcfa374db596
+DIST tickets-1.1.tar.bz2 63420 RMD160 bbc854fd7005ca55acc2dc3f7857fd5d1baaaf04 SHA1 4ab7bee2fd41873c853958fdde4defda7ba282f9 SHA256 058e6d9f5535039df0ee4a93c8f0e8cc65538fa0b4cedb600282d3751ae41549
+EBUILD notifyserv-1.1.ebuild 433 RMD160 9fcd088a4a8f16ff29dbbfed2b1b879ea9431c07 SHA1 70c7d332d3bf038f07c1befb9cc6be0f738c55fd SHA256 057b22da805fd51f6419348119898f5e4f1478694b908bba655405872864ea59
+EBUILD notifyserv-2.0.ebuild 401 RMD160 2d54d59794d03be2eb6d9e626436073aa13aef19 SHA1 97118a6dd438fc3e0a152a22f2f18831d4b49cac SHA256 d3c2ada6903a105e8d86b1c420ace36e333bcc143f94f3877f72410a28624232
+EBUILD notifyserv-9999.ebuild 548 RMD160 e78b5695e1dfa0b5ba93d07a76db16536cc9965e SHA1 8fd75b3b1ae055f3b49fa24107d0027fd15640f5 SHA256 a580463a0aebd36aabe5bfc1c8cc9c9b5b2a0c40171f1b02ac27d0eac421b5ff
+MISC ChangeLog 666 RMD160 8cb71603f9e3576ffeb510ccf960342b059b2248 SHA1 c6fd8902d243f99582130f3700173b0954413bd3 SHA256 ee3cedc4c05890f38a5d13eac965ad1cc330474c6b56e6d7b010132ca60cf2a0
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.9 (GNU/Linux)
+
+iEYEARECAAYFAkmF7eQACgkQKhnDs22gwa/sVgCglusDeUfav/vMv2FmfIZZmO+J
+z28An1oC9gCdlfGYW7SbgQ0Z39d820VS
+=rwPZ
+-----END PGP SIGNATURE-----
diff --git a/net-misc/notifyserv/notifyserv-1.1.ebuild b/net-misc/notifyserv/notifyserv-1.1.ebuild
new file mode 100644
index 0000000..1fc67bc
--- /dev/null
+++ b/net-misc/notifyserv/notifyserv-1.1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="IRC Notification System"
+HOMEPAGE="http://angelos.unkreativ.org"
+SRC_URI="http://angelos.unkreativ.org/tickets-${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/net-misc/notifyserv/notifyserv-2.0.ebuild b/net-misc/notifyserv/notifyserv-2.0.ebuild
new file mode 100644
index 0000000..d833881
--- /dev/null
+++ b/net-misc/notifyserv/notifyserv-2.0.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="IRC Notification System"
+HOMEPAGE="http://ngls.zakx.de/notifyserv"
+SRC_URI="http://ngls.zakx.de/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS
+}
diff --git a/net-misc/notifyserv/notifyserv-9999.ebuild b/net-misc/notifyserv/notifyserv-9999.ebuild
new file mode 100644
index 0000000..6e5ba38
--- /dev/null
+++ b/net-misc/notifyserv/notifyserv-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit git
+
+DESCRIPTION="IRC Notification System"
+HOMEPAGE="http://angelos.unkreativ.org"
+EGIT_REPO_URI="git://gitopia.de/notifyserv.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="sys-apps/help2man"
+RDEPEND=""
+
+src_compile() {
+ ./autogen.sh --prefix=/usr
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}