summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/windowlab/windowlab-1.29.ebuild')
-rw-r--r--x11-wm/windowlab/windowlab-1.29.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-wm/windowlab/windowlab-1.29.ebuild b/x11-wm/windowlab/windowlab-1.29.ebuild
new file mode 100644
index 000000000000..bdba75aaf0dc
--- /dev/null
+++ b/x11-wm/windowlab/windowlab-1.29.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/windowlab/windowlab-1.29.ebuild,v 1.1 2005/05/22 15:11:56 usata Exp $
+
+IUSE=""
+
+DESCRIPTION="WindowLab is a small and simple window manager of novel design."
+HOMEPAGE="http://www.nickgravgaard.com/windowlab/"
+SRC_URI="http://www.nickgravgaard.com/${PN}/${P}.tar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+DEPEND="virtual/x11"
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dobin windowlab
+
+ newman windowlab.1x windowlab.1
+ dodoc CHANGELOG README
+
+ dodir /etc/X11/windowlab
+ insinto /etc/X11/windowlab
+ newins menurc.sample menurc
+
+ dodir /etc/X11/Sessions
+ echo "/usr/bin/${PN}" > ${D}/etc/X11/Sessions/${PN}
+ fperms a+x /etc/X11/Sessions/${PN}
+}