summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xteddy/xteddy-2.2.ebuild')
-rw-r--r--x11-misc/xteddy/xteddy-2.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-misc/xteddy/xteddy-2.2.ebuild b/x11-misc/xteddy/xteddy-2.2.ebuild
new file mode 100644
index 000000000000..07ee6bee9a98
--- /dev/null
+++ b/x11-misc/xteddy/xteddy-2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xteddy/xteddy-2.2.ebuild,v 1.1 2011/11/19 04:20:20 radhermit Exp $
+
+EAPI="4"
+
+inherit autotools
+
+DESCRIPTION="A cuddly teddy bear (or other image) for your X desktop"
+HOMEPAGE="http://webstaff.itn.liu.se/~stegu/xteddy/"
+SRC_URI="http://webstaff.itn.liu.se/~stegu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/imlib2
+ x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS=( AUTHORS README ChangeLog NEWS xteddy.README )
+
+src_prepare() {
+ # Fix linking order for --as-needed
+ sed -i -e "s/AM_LDFLAGS/xteddy_LDADD/" Makefile.am || die
+ eautoreconf
+}