summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/xclock/xclock-1.0.2.ebuild')
-rw-r--r--x11-apps/xclock/xclock-1.0.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-apps/xclock/xclock-1.0.2.ebuild b/x11-apps/xclock/xclock-1.0.2.ebuild
new file mode 100644
index 000000000000..595f1a0bc5fe
--- /dev/null
+++ b/x11-apps/xclock/xclock-1.0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xclock/xclock-1.0.2.ebuild,v 1.1 2006/04/29 16:35:10 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xclock application"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="xprint"
+RDEPEND="x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXft
+ x11-libs/libxkbfile
+ x11-libs/libXaw"
+DEPEND="${RDEPEND}"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}