summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libcap-ng/libcap-ng-0.6.2.ebuild')
-rw-r--r--sys-libs/libcap-ng/libcap-ng-0.6.2.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sys-libs/libcap-ng/libcap-ng-0.6.2.ebuild b/sys-libs/libcap-ng/libcap-ng-0.6.2.ebuild
index bcde9c68e70f..d6cb8f4b7854 100644
--- a/sys-libs/libcap-ng/libcap-ng-0.6.2.ebuild
+++ b/sys-libs/libcap-ng/libcap-ng-0.6.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/libcap-ng-0.6.2.ebuild,v 1.1 2009/10/26 07:44:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/libcap-ng-0.6.2.ebuild,v 1.2 2010/02/01 19:14:31 armin76 Exp $
EAPI="2"
-inherit eutils autotools
+inherit eutils autotools flag-o-matic
DESCRIPTION="POSIX 1003.1e capabilities"
HOMEPAGE="http://people.redhat.com/sgrubb/libcap-ng/"
@@ -12,7 +12,7 @@ SRC_URI="http://people.redhat.com/sgrubb/libcap-ng/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~sparc ~x86"
IUSE="python"
RDEPEND="sys-apps/attr
@@ -24,6 +24,8 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${PN}-gentoo.patch
eautoreconf
+
+ use sparc && replace-flags -O? -O0
}
src_configure() {